Downgrade Moto G 2015 from Android 6.0 to 5.1.1

  • 1
  • Question
  • Updated 2 years ago
  • Answered

Can you please provide instructions including factory firmware images in order to downgrade my Moto G 2015 from Android 6.0 to 5.1.1?

Since the upgrade, my phone's battery life has been terrible. There are a few other issues, but the main issue that others have experienced as well is the battery life. My wife has the same phone with the same issue.

Please advise.

Photo of thelouisguy

thelouisguy

  • 224 Points 100 badge 2x thumb

Posted 2 years ago

  • 1
Photo of Navdeep Singh

Navdeep Singh

  • 470 Points 250 badge 2x thumb
Did you try reseting you phone? Keep leadt amount of apps on thr phone and then check if the battery performs well.
Photo of thelouisguy

thelouisguy

  • 224 Points 100 badge 2x thumb
I did a factory reset before upgrading and a factory reset after upgrading. Worst offender is WiFi and Google Calendar. Solutions of disabling WiFi and disabling Calendar syncing did not help.
Photo of JeremyESQ

JeremyESQ

  • 2,174 Points 2k badge 2x thumb
Have you tried using a third-party app like BatteryDoctor? This may help pinpoint the root cause of why your phone battery is draining faster than normal
Photo of Larry Hutnik

Larry Hutnik

  • 200 Points 100 badge 2x thumb
my phone does the same thing.  Seriously thinking of trading for a samsung.  but still have months to go on my tab.  I hate my moto G.
Photo of Patrick Lebel

Patrick Lebel

  • 200 Points 100 badge 2x thumb
Try my solution lower in the page. I had this problem with a nexus 5, my moto x play, my gf moto g and I fixed them all this way.
Photo of thelouisguy

thelouisguy

  • 224 Points 100 badge 2x thumb
The Moto G is a great phone. It was perfect running 5.1.1. I just want to go back to 5.1.1.
Photo of Patrick Lebel

Patrick Lebel

  • 200 Points 100 badge 2x thumb
Did you fix your problem?
Photo of thelouisguy

thelouisguy

  • 224 Points 100 badge 2x thumb
I cleared the cache partition, factory reset the phone, cleared the cache partition again, all while in recovery and it seemed to have worked work the past week. The Google Calendar issue is gone as well as the WiFi issue. Both do take up quite a bit of battery life on occasion, but they never seem to get stuck in wakelock like they used to. I do find that turning the phone completely off every couple of days helps with the wakelock issue.

Thank you!
Photo of Chadwick

Chadwick, Mobile Master

  • 33,072 Points 20k badge 2x thumb
I recommend waiting a few battery cycles before downgrading. When a new version is put on ur phone it can mess with your battery. I flash a lot of ROMs and battery life is almost ALWAYS bad for the first 1 or 2 cycles.
Photo of Paul Deschamps

Paul Deschamps, Mobile Master

  • 199,580 Points 100k badge 2x thumb
I agree although I see battery life getting better for up to a week or two of usage before it levels off after an update.
Also perform updates or factory reset with 100% battery and while plugged in, I've always done this and never had any battery issues while others with the same phone are experiencing issues so definitely something to try OP
Photo of thelouisguy

thelouisguy

  • 224 Points 100 badge 2x thumb
I have had the upgrade for since January, 2 and a half months.
Photo of Patrick Lebel

Patrick Lebel

  • 200 Points 100 badge 2x thumb
*edit *
This will not make a downgrade, but rather, fix your battery issues.

You have to clear the partition cache. Sometimes, with ota upgrade, old apps settings remains and cause trouble. You should not loose any data, but backup anything that worth it.


Make sure the battery is at least 50 percent and that the phone is plugged.


Shut down the phone. Restart it holding volume down + power. Hold both key for a while until you see a menu.


Press the volume key until recovery appears on the right and push power to select it


Wait until a green robot appears and by holding the vol up key, press the power button once.


A menu on the left will appear and using the volume down key, highlight the wipe cache partition and press the power button.


Wait until the end of the process then reboot phone.
(Edited)
Photo of thelouisguy

thelouisguy

  • 224 Points 100 badge 2x thumb
Okay, thank you. I will try it tonight.
Photo of Patrick Lebel

Patrick Lebel

  • 200 Points 100 badge 2x thumb
Downgrading require an unlock code from Motorola, voiding the warranty, finding the right os image for your phone, downloading Android sdk and install it and be comfortable with shell command sush as adb xxxx...

So, I won't guide you to that as I don't want to be responsible if you brick your phone..

Turning off Wi-Fi location in localization option will greatly help the Wi-Fi issues.

In localization, tap the 3 dots in the upper right corner and select scanning.. Turn off Wi-Fi scanning

It won't cure the problem, but attenuate it.
Photo of thelouisguy

thelouisguy

  • 224 Points 100 badge 2x thumb

Thank you, I am comfortable with all this, I have flashed many phones in the past. I was going to use the ROM I had found here: http://forum.xda-developers.com/2015-moto-g/general/index-moto-g-factory-firmware-images-t3169639
but was looking to see if Koodo would be able to provide an official version.

Thank you for your help.

Photo of Patrick Lebel

Patrick Lebel

  • 200 Points 100 badge 2x thumb
Ah.. So I'm wondering if a 6.0.1 rom can be found for that phone.. There is a lot of variant for this phone.

And the telus rom from the page you linked should work as koodo is a telus parent..
Photo of Patrick Lebel

Patrick Lebel

  • 200 Points 100 badge 2x thumb
Disabling the Wi-Fi won't hell because the bug is caused by the localization service that is always using the Wi-Fi to get the position, even if it is turned off.
Photo of Navdeep Singh

Navdeep Singh

  • 470 Points 250 badge 2x thumb
go to wifi setting and then to the advanced settings .  turn off the the always allow scanning and one more setting is to change the wifi frequency. hope this works
Photo of Patrick Lebel

Patrick Lebel

  • 200 Points 100 badge 2x thumb
In 6.0, this setting is now in the localization option. You click the 3 dots in the upper right corner to disable both wifi and Bluetooth location search