Doesn't work cellular data

  • 1
  • Question
  • Updated 2 years ago
  • Answered
I have a prepaid account. Was out of Canada for almost a month. When got back topped up my phone and got two boosters (minutes + 1Gb internet). Minutes are active, but when trying to go online - it says that cellular data is not working. What is the problem? Should I contact customer support?
Photo of Ved Make

Ved Make

  • 130 Points 100 badge 2x thumb
  • confused

Posted 2 years ago

  • 1
Photo of Mathieu

Mathieu, Mobile Master

  • 60,848 Points 50k badge 2x thumb
Hi Ved,

I would recommend shutting down the phone and removing the SIM card for a few moments, then putting the SIM card back in and powering the phone on again. 
Photo of Ved Make

Ved Make

  • 130 Points 100 badge 2x thumb
Tried already :(
Photo of Mathieu

Mathieu, Mobile Master

  • 60,848 Points 50k badge 2x thumb
Are you sure that the add-on is active?
Photo of Ved Make

Ved Make

  • 130 Points 100 badge 2x thumb
Pretty sure, but could be unactive
Photo of Sophia

Sophia, Mobile Master

  • 142,984 Points 100k badge 2x thumb
I'm pretty sure you just need to check if your network settings are correct, Ved... on a lot of phones this can be found under "More Networks", "Mobile Networks", see if Mobile data is checked and the Access Point Names set to sp.koodo.com (and ticked) :) Then reboot.
(Edited)
Photo of Mathieu

Mathieu, Mobile Master

  • 60,848 Points 50k badge 2x thumb
dfbutt, you see the LTE in the top left of the screenshots. I'm pretty sure that only displays when the data is turned on.
Photo of Ved Make

Ved Make

  • 130 Points 100 badge 2x thumb
I have turned on the cellular data. Maybe I should write something down in APN settings?
Photo of Sophia

Sophia, Mobile Master

  • 142,984 Points 100k badge 2x thumb
Those settings look correct to me... and I don't think you can change anything on an iPhone (I didn't notice that you have an iPhone before)... 

You said you bought a 1GB booster, when you log in, does it show under "Booster usage" that you have data available to you? 

This is what it looks like for me:

Photo of Ivan

Ivan, Mobile Master

  • 96,634 Points 50k badge 2x thumb
You can change them on an unlocked iPhone.
Photo of Ivan

Ivan, Mobile Master

  • 96,634 Points 50k badge 2x thumb
It honestly sounds like the booster wasn't applied to the account. But just in case it's your phone, please try resetting your network settings:

Settings > General > Reset > Reset Network Settings.

You'll lose WiFi passwords.
Photo of Julie

Julie, Official Rep

  • 2,344 Points 2k badge 2x thumb
Hey Ved! Has resetting your network settings helped? Were you ever able to use Data before? You can also check your Self-Serve or reach out to customer service to make sure that the booster has been successfully added! Keep us posted :)! 

This conversation is no longer open for comments or replies.