display isn't giving my # when I call out

  • 1
  • Question
  • Updated 4 years ago
  • Answered
when I got this phone the agent told me and it's on my status that I should have call display in and outbound but I only have it in, when I call, people only see private number to unknown number.
can you fix this?? I don't want my name only my #
Photo of Nancy Johnston

Nancy Johnston

  • 90 Points 75 badge 2x thumb

Posted 4 years ago

  • 1
Photo of Daniel Kim

Daniel Kim, Mobile Master

  • 34,736 Points 20k badge 2x thumb
maybe the other people don't have inbound call display? just a guess but it could be a possibility.
Photo of Jonathan I

Jonathan I, Mobile Master

  • 114,344 Points 100k badge 2x thumb
Besides what Daniel Kim said, if you have an Android, then it could be that your call settings are set to hide your #. Go to the call dialer > Settings > More Settings. Ensure that outgoing Caller ID is set to show number.