Did not receive the 10% ATU credit after automatic top-up

  • 1
  • Question
  • Updated 9 months ago
Automatic top-up was August 15th - the 10% discount has not been applied for that top-up. Can someone please advise as to how we can get that corrected. Thank you.
Photo of Gary

Gary

  • 222 Points 100 badge 2x thumb

Posted 9 months ago

  • 1
Photo of Sophia

Sophia, Mobile Master

  • 141,558 Points 100k badge 2x thumb
You can contact Koodo on Facebook private messenger to have to discount applied. That said though, are you absolutely sure you did not receive the credit? Have you received it in the past?
Photo of Gary

Gary

  • 222 Points 100 badge 2x thumb
Thank you, Sophia. Yes, absolutely certain; we have received it for earlier months, but this month it was not applied (the top up was successful and is in the transaction history, however the ATU is not, and the account balance hasn't changed after the top-up, which it ought to have if the ATU was applied).
Photo of Sophia

Sophia, Mobile Master

  • 141,558 Points 100k badge 2x thumb
Did you get your credit, Gary?
Photo of Gary

Gary

  • 222 Points 100 badge 2x thumb
Nope, not as yet anyway -- sent a Facebook private message yesterday afternoon, which got an immediate "we are a bit backed up and will take a few hours to respond" automatic reply ... and nothing since. We'll give it 24 hours from the original message, and try again if we've still not got a reply.

This is the 3rd issue we've had with our account in the last month (there are 2 other things that've happened which we've already brought to Koodo's attention) - kinda makes one wonder what's going on with their system?

Thanks for asking! 
Photo of Sophia

Sophia, Mobile Master

  • 141,558 Points 100k badge 2x thumb
Yeah, the prepaid system can be buggy, especially for some. I haven't experienced (m)any problems with it myself, but once things go wrong, they seem to go wrong in spades! I'm sure you will get a reply soon, and as you said, if not try again. Make sure you get that credit :D