Delayed incoming text messages (anywhere from 10 to 3 or 4 hours

  • 1
  • Question
  • Updated 2 years ago
  • Answered
I'm using a unlocked Samsung Galaxy S6 Edge (32gb model) and am having frustrating issues with the service. I am getting delayed text messages quite frequently, anywhere from 15 minutes delayed up to multiple hours. I have checked the service map and there is no reason why I should be having these issues. I have tried rebooting the phone, I've tried factory restoring the phone, I have called once to koodo (prior to factory restore) and nothing seems to fix the issue. I generally have wi-fi on for the obvious reason of conserving data, I have very mainstream apps, so that shouldn't be a problem either. Anyone have some insight? Im running on Android 5.1.1 if that makes anything any clearer.

Photo of TJ Leung

TJ Leung

  • 70 Points
  • frustrated

Posted 2 years ago

  • 1
Photo of Paul Deschamps

Paul Deschamps, Mobile Master

  • 193,200 Points 100k badge 2x thumb
Haven't experienced this issue with either my S6 or s6 edge but there are others that are experiencing the same issue as you. According to them one fix is to run the phone on the WCDMA only setting and not the LTE /WCDMA auto setting. Another person sent their phone for repair and after a few days have not has the issue so not sure what to tell you other than those seem to be the solutions right now.
Photo of Asaad


  • 202 Points 100 badge 2x thumb
The delay is most likely caused by you moving in and out of Wifi and when your phone connects to mobile networks only, i have this issue too. Here is a fix only for when your phone is idle, the solution is to temporarily turn wifi off. 
Photo of Jonathan I

Jonathan I, Mobile Master

  • 114,344 Points 100k badge 2x thumb
Turn off LTE. It's a glitch with that network for some reason. It's not even with Koodo; I'm with Rogers and have the same issue. I'm gonna send a message to Samsung about it.