Data usage cycle on Samsung Galaxy S2X

  • 1
  • Question
  • Updated 4 years ago
  • Answered
How do I change the data usage cycle on my Samsung Galaxy S2X? I can click on the current cycle (which is based on when I bought my phone), but I would like to change it so that it coincides with my billing cycle... and I can't seem to find this option. Thanks!
Photo of Josée St-Jean

Josée St-Jean

  • 130 Points 100 badge 2x thumb

Posted 5 years ago

  • 1
Photo of Zaphod Beeblebrox

Zaphod Beeblebrox

  • 50,808 Points 50k badge 2x thumb
When you are in the data usage section of the phone, there should be a "data usage cycle" with dates already there. Tap on the dates and it will give you the option to change the cycle. The date you should change it to is the start of your bill cycle
Photo of Zaphod Beeblebrox

Zaphod Beeblebrox

  • 50,808 Points 50k badge 2x thumb
Settings> Data Usage> Datausage Cycle> Change Cycle> (whatever the start date of you bill cycle is)
Photo of Josée St-Jean

Josée St-Jean

  • 130 Points 100 badge 2x thumb
Thank you for your reply, Tyler C. When I tap on the dates that currently appear, it does not give me the option to change them - the dates simply pop up and when I tap on them again, they minimize... so I'm quite confused!
Photo of Zaphod Beeblebrox

Zaphod Beeblebrox

  • 50,808 Points 50k badge 2x thumb
Hmm...Definatley a mystery to me. I was using an S2X when I posted the steps. When I did the steps myself, I did what you did but the pop up gave me the original dates entered as well as "change cycle" right underneath.

I do not see any other way within the phone to change it. There is the 3g watchdog app you can download as well. I have it on my phone and it's basically the same thing.

Before that, though, let's see if anyone else has an idea why it won't let you change the dates. <-- Up to you on this one.
Photo of Josée St-Jean

Josée St-Jean

  • 130 Points 100 badge 2x thumb
Thanks again... yeah, I don't know why the "change cycle" option isn't appearing for me. I will wait to see if anyone else has a suggestion, and if not, I will likely go to a Koodo kiosk to ask them to help me out.
Photo of Carlos Toledo

Carlos Toledo

  • 122 Points 100 badge 2x thumb
I had the same problem. Here is the solution that works for me with my Note 2.

1. Activate Data Usage.
2. In the Data Usage section, tap the left button for options or settings and Uncheck 'Auto Sync Data'.
3. Now close the Data Usage app. I mean close it also from the background not just going to Homescreen. To be sure close all apps on background.
4. Open Settings again and Data Usage section. Now 'Change Cycle' should appear at the bottom of the drop down menu.
5. Activate 'Auto Sync Data' and Turn Off Data Usage if you don ́t need it now.

Let me know if this help.

This conversation is no longer open for comments or replies.