Data problem

  • 1
  • Question
  • Updated 2 years ago
  • Answered
Hi, I got an unlocked galaxy S5 (G900V, from Verizon). Talk is ok, but after apn setting , I do not have data. Any suggestion?
Photo of Able


  • 486 Points 250 badge 2x thumb

Posted 2 years ago

  • 1
Photo of Goran

Goran, Mobile Master

  • 82,882 Points 50k badge 2x thumb
I don't think that it will work on Koodo actually. Verizon phones are weird like that because except for a couple of the newest phones where talk and data use combined CDMA and "4G" networks to work. I'm surprised it's data that's not working. My understanding is its voice that's still CDMA.
Photo of Goran

Goran, Mobile Master

  • 82,882 Points 50k badge 2x thumb
So it actually has lte band 4 and is 3g quad band so it should be working without issues surprisingly. Can you go into network settings and make sure that you don't have an option chosen for CDMA? Like just for example "hspa/lte"
Photo of Able


  • 486 Points 250 badge 2x thumb
Here is the situation,

Voice is good no data
No name of Koodo on the screen
Network mode three options to choose, Global, LTE/CDMA, LTE/GSM/UMTS, tried all, non is working
When I manually select network, Bell, Telus, Rogers come up after search
Photo of Able


  • 486 Points 250 badge 2x thumb
Yes Goran, That is right, this site shows the phone has all necessary bands.
Photo of BobTheElectrician


  • 57,018 Points 50k badge 2x thumb
Try re-starting phone without the SIM. Will of course give you an error message but should flush any internal network settings. Turn off, wait a few minutes and re-start with the SIM inserted.

Double-check the APN values and network choices.
Photo of grampad


  • 1,876 Points 1k badge 2x thumb
If you don't see Koodo as a Network, try adding it to your Network in settings: try these commands then add info from Bob. Tap the menu key. Tap System settings. Tap More... Tap Mobile network.
Tap Access Point Names. Press the Menu button Tap New APN:
Photo of rikkster

rikkster, Mobile Master

  • 66,272 Points 50k badge 2x thumb
From the dial pad, dial *#*#4636#*#* and select Phone Information. Scroll down to 'Set preferred network type' and tap the dropdown menu. Make note of what appears there, then select either LTE/WCDMA (4G/3G data) or WCDMA Only (3G data). Do not reboot or restart the phone. To exit, use the back arrow key or press the home button.
Photo of Tayeb A

Tayeb A, Employee

  • 17,720 Points 10k badge 2x thumb
Hey Able,

Have you tried the above suggestions? Do you still need help?

Keep us posted!
Photo of Able


  • 486 Points 250 badge 2x thumb
Thanks a lot for all helpful helps!
Here is the update,

I applied suggestions, and specially tweaking the apn settings, and got mobile data.
When I start mobile data, I can see 3G for a short while, then steady 4G LTE.
Thanks again,
But, somthing is strange. When the screen turns on, I can see TELUS instead of Koodo. When I  swipe the screen, I do not have neither Koodo nor Telus, but it does not affect the service.

The next challenge is to upgrade from Verizon Android 5 to Android 6.
Photo of Ivan

Ivan, Mobile Master

  • 95,438 Points 50k badge 2x thumb
It's quite normal to see Telus instead of Koodo when using an unlocked phone from elsewhere. Some phones will display 302220 (Telus' MCC/MNC number) - my OnePlus X did this.

Koodo runs on the Telus network.
Photo of Mobifree Unlocking

Mobifree Unlocking

  • 170 Points 100 badge 2x thumb
Since voice is working fine, then HSPA data should work fine on the device.

TELUS / KOODO LTE may not work on that particular phone

The amazon page has incorrect information. 
Photo of Able


  • 486 Points 250 badge 2x thumb
I managed to upgrade to android 6.0.1( Verizon phone on  Koodo network)

I tried several times to upgrade from the phone itself, but I always got the message " server is not available". Googling showed that many users have this problem without any solution. Some user recommended ordering new sim card from Verizon.

Here is what I did.
-Remove Koodo sim
-Run Ivacy VPN on a PC and set a US VPN server
-Connect phone to PC by a cable
-Then a Verizon/Samsung window started installing driver for the phone
-Once finished, I could upgraded from the driver.

I am not sure if any of the above steps is unnecessary. Anyway, it worked for me.

This conversation is no longer open for comments or replies.