Data plan is not working? It says I have it but I cannot connect to Internet using data.

  • 1
  • Question
  • Updated 9 months ago
Have the 30 plan for the US but the data won't
Work. I have data enabled in my settings but I cannot connect to the Internet without wifi.
Photo of Natalie A Schaff

Natalie A Schaff

  • 182 Points 100 badge 2x thumb
  • frustrated

Posted 9 months ago

  • 1
Photo of Robert

Robert, Mobile Master

  • 103,784 Points 100k badge 2x thumb
Hello Natalie,

Did you activate data roaming on your phone?
Photo of Goran

Goran, Mobile Master

  • 90,800 Points 50k badge 2x thumb
Did you also enable data roaming? Try restartinyour phone after you check
Photo of Natalie A Schaff

Natalie A Schaff

  • 182 Points 100 badge 2x thumb
Yes roaming is activated.
Photo of Natalie A Schaff

Natalie A Schaff

  • 182 Points 100 badge 2x thumb
Restarting did not help.
Photo of Natalie A Schaff

Natalie A Schaff

  • 182 Points 100 badge 2x thumb
I don't usually carry a plan in Canada but got the plan for while I am in the states. Could this be an issue? For $75 I better get this to work.
Photo of Natalie A Schaff

Natalie A Schaff

  • 182 Points 100 badge 2x thumb
My wifi is spotty. Still hoping for a response
Photo of David

David, Mobile Master

  • 89,180 Points 50k badge 2x thumb
Your phone should work for pay-per-use data even without a plan. Do you have a data block on your phone, to,prevent overages in Canada? If so that may be the root of your problem.
Photo of Natalie A Schaff

Natalie A Schaff

  • 182 Points 100 badge 2x thumb
Yes that could be. How do I fix it?
Photo of Mayumi

Mayumi, Mobile Master

  • 112,838 Points 100k badge 2x thumb
If you have a data block, then you have to contact Koodo to remove it.
Send them a PM through FB and request it.
https://www.facebook.com/Koodo
Photo of Kim Dillon

Kim Dillon

  • 110 Points 100 badge 2x thumb
Hey! I am having the same problem as Natalie. I also enabled roaming. How does one stop the data blocking? What is the procedure?
Photo of Mayumi

Mayumi, Mobile Master

  • 112,838 Points 100k badge 2x thumb
Did you restart your phone?  Did you get a Roaming add-on?
Make sure you have a $0 International Data Roaming add-on activated.
Login to self serve and check it. Also if you have a data block ion your account.

If you have an add-on : Data block w pics, then you might be able to removed it through self serve. But if you get an error message, you need to contact them.
Photo of BobTheElectrician

BobTheElectrician

  • 62,064 Points 50k badge 2x thumb
On an Android phone, there are a few additional things you can try if US roaming is not working:

In your mobile network settings, change network type to EXCLUDE LTE. Some locations may only be working on the older 3G standard.

In network providers, deselect automatic and let the phone populate with the eligible local networks (may take a few minutes). Then select either AT&T or T-Mobile manually.

Don't forget to revert the setting when you get back to Canada.