Data not working with international roam plan. Phone and text ok. In Europe.

  • 1
  • Question
  • Updated 11 months ago
  • Answered
Archived and Closed

This conversation is no longer open for comments or replies and is no longer visible to community members.

I have added the international roaming plan for phone and data. The phone and text works but data doesn't. I have the roaming options on , iPhone 7 and have rebooted. I am traveling in Europe . What ca I do?
Photo of Brian Anderson

Brian Anderson

  • 130 Points 100 badge 2x thumb

Posted 11 months ago

  • 1
Photo of Chad Burr

Chad Burr, Mobile Master

  • 203,968 Points 100k badge 2x thumb
Goto

Settings...Cellular...And make sure the data roaming switch is on.

Also make sure the free international data roaming add on is added to your account in self serve.
(Edited)
Photo of Brian Anderson

Brian Anderson

  • 130 Points 100 badge 2x thumb
It is on and I have restated the phone, more than once.

Thanks
Photo of Chad Burr

Chad Burr, Mobile Master

  • 203,968 Points 100k badge 2x thumb
Edit: Also make sure the free international data roaming add on is added to your account in self serve.
(Edited)
Photo of Brian Anderson

Brian Anderson

  • 130 Points 100 badge 2x thumb
It is and confirmed
Photo of Chad Burr

Chad Burr, Mobile Master

  • 203,968 Points 100k badge 2x thumb
Man that's odd

Have you tried searching for a different available carrier by turning off automatic and allowing your phone to scan?
Photo of Brian Anderson

Brian Anderson

  • 130 Points 100 badge 2x thumb
I have done that as well and tried all 4 available carriers. Also, phone and text work on the automaticity selected vodaphone carrier.

Thanks
Photo of Erwin

Erwin

  • 23,546 Points 20k badge 2x thumb
Hey Brian,

Can you check your Koodo Self-Serve and see if you've gone over your international data? Koodo blocks your data if you have gone over your data by $100.
Photo of Brian Anderson

Brian Anderson

  • 130 Points 100 badge 2x thumb
I did check. Phone and text usage show up but zero data used.

I removed the sim, rebooted antd then reinstalled it with no luck.

I see where some othe users with similar issues, Koodo has adjusted some settings and the had them cycle airplane mode. How can I get them involved?

Thanks for your help!
Photo of Chad Burr

Chad Burr, Mobile Master

  • 203,968 Points 100k badge 2x thumb
I've reached out to Koodo on this. Others may have other suggestions as well before Koodo chimes in.
(Edited)
Photo of Ranjan

Ranjan, Official Rep

  • 28,608 Points 20k badge 2x thumb
Hi Brian - unfortunately I'm unable to pull up your account without authenticating you. Normally as an employee I can search using the email address from your profile here, but looks like it may be different. In this case I'd recommend you send us a private message via Facebook, where an agent can validate you and help look into the matter. 

Before doing so, please also check your self-serve profile to ensure you have the $0 International Data Roaming add-on activated, as well as the $0 Pay-Per-Use Intl Long Distance option. If one or both are not on your account already, you can add them by selecting 'Manage' under the 'Mobile Services' section in Self Serve (be sure to reboot your phone after adding them, and then try using data). Let us know if you're able to resolve the issue this way. 
Photo of Brian Anderson

Brian Anderson

  • 130 Points 100 badge 2x thumb
OK, I changed my primary email to the one I use for Koodo. Please check again. I am not a Facebook user.

As stated earlier, self serve shows the international roaming and data plan added. It correctly shows 0 data used as well as being accurate on the text and phone usage as they work fine. Data does not work.

If you read my previous posts you will see I have read the message board and tried all the suggestions. How about you provide me contact information for Koodo support?

Thanks
Photo of Ranjan

Ranjan, Official Rep

  • 28,384 Points 20k badge 2x thumb
Thanks for updating your email - was able to pull up your account with this.

Looks like international data roaming was missing, which I've gone ahead and added to the number with the roaming package (I see two numbers on your account).

Please try rebooting and let us know if this resolves the problem.
Photo of Brian Anderson

Brian Anderson

  • 130 Points 100 badge 2x thumb
That worked, thank you!

This conversation is no longer open for comments or replies.