Data not working on iPhone 6s

  • 1
  • Question
  • Updated 2 years ago
  • Answered
Archived and Closed

This conversation is no longer open for comments or replies and is no longer visible to community members. The community moderator provided the following reason for archiving: 1-866

Today, I changed my plan to include 500 mb of data but when I enable cellular data and LTE it doesn't work. The symbols don't show up and the pages in Safari won't load. I've tried resetting network setting, restarting my phone, and taking out the SIM card but nothing seems to work. I'm paying $10 more just for the data and It's not even working. 
Photo of Hamzah Hashmi

Hamzah Hashmi

  • 110 Points 100 badge 2x thumb
  • Annoyed

Posted 2 years ago

  • 1
Photo of Goran

Goran, Mobile Master

  • 97,238 Points 50k badge 2x thumb
So this only started happening as soon as you changed your plan? And that's all you did around the time you lost data access?
Photo of Hamzah Hashmi

Hamzah Hashmi

  • 110 Points 100 badge 2x thumb
Actually, I've never used data on my phone. My old plan had pay per use data but I never used it. Also, I don't think I've been billed for it yet because my account says there are no bills to show. 
Photo of Goran

Goran, Mobile Master

  • 97,238 Points 50k badge 2x thumb
It would be be proration thing an show up on your next bill. Le us know if Robert's suggestion of checking if you have data block on is th case.
Photo of Robert

Robert, Mobile Master

  • 106,940 Points 100k badge 2x thumb
Did you ever have data block on your account? If yes you would need to remove it
Photo of Theminh

Theminh

  • 60 Points

I'm getting Call failed to 611. Any other alternative to reach you? Thanks

Photo of rikkster

rikkster, Mobile Master

  • 68,316 Points 50k badge 2x thumb
Try *611. Or call 1-866-995-6636 from a landline or friends phone.
Photo of Hamzah Hashmi

Hamzah Hashmi

  • 110 Points 100 badge 2x thumb
Thanks. I'll try that.
Photo of Hamzah Hashmi

Hamzah Hashmi

  • 110 Points 100 badge 2x thumb
Turns out I did have a data block. They removed it and now it's working. Thanks everyone for your help.
Photo of Tayeb A

Tayeb A, Employee

  • 18,208 Points 10k badge 2x thumb
Thank you Hamzah! Glad to hear your issue has been resolved.  

This conversation is no longer open for comments or replies.