Data not working LG G3

  • 2
  • Question
  • Updated 2 years ago
  • Answered

Recently added data to my phone package.  It is not working.  When I try going on the internet, it says "Your device is offline". Aeroplane mode is NOT on. Signal strength is good. Read previous posts and tried to set-up APN as instructed and it still doesn't work.  Is anyone able to help?

Thanks in advance

Photo of Nathalie


  • 80 Points 75 badge 2x thumb

Posted 2 years ago

  • 2
Photo of BobTheElectrician


  • 57,040 Points 50k badge 2x thumb
Check that mobile data is enabled on your handset. Verify the APN values in Mobile networks preferences (see screen shot below).

Remove the SIM and re-start your phone. This will give an error message, but refresh your data connection from Ø. Re-insert the SIM and restart.

If you still have no data, go back to mobile network preferences and toggle betweek LTE/WCDMA or just WCDMA being enabled. This may help if reception is poor in your area.

If you want the shock-free data features enabled, go into your self-serve notification preferences and make sure Koodo is allowed to text you.

Lastly, if you have a data block at the account level, you will have to contact Koodo to get it lifted. Send them a private message on their Facebook page to avoid spending time on hold.
Photo of Klare Getty

Klare Getty

  • 62 Points
I registered the phone have a number etc but l can't sign in it says z"Do not recognise the username or password help
Photo of BobTheElectrician


  • 57,018 Points 50k badge 2x thumb
Have you already registered for self-serve or did you just arrive home from the store with an activated phone and leave it at that?

On post-paid, registering for self-serve is a separate process you do on your own. It would be better for Koodo to integrate the 2 processes, the way it does for pre-paid.

If you are already registered and your user name or password no longer work, you will have to contact customer service by phone or by sending a private message on Koodo's Facebook or Twitter page.

This conversation is no longer open for comments or replies.