Data booster is not activating and not shownig in booster usage

  • 1
  • Question
  • Updated 3 years ago
  • Answered
I had a 15$ base plan, I upgraded to the $25 base plan and added a $30 data booster to it. However, I have not been able to use any data on my phone. I checked the account booster usage and my most data booster is not showing there. I added *another* $30 data booster out of frustration since I need data now, but I am still not seeing it in the booster usage view and my phone still does not have data. Why am I paying for this service, if it is not working?
Photo of Aras


  • 70 Points
  • frustrated

Posted 3 years ago

  • 1
Photo of Ahmad


  • 96,062 Points 50k badge 2x thumb
Hey Aras. This shouldnt happen and definetly is a fluke. If you call *611 from your Koodo phone and choose option 6 you can speak with a rep who can add it for you. It says you'll be charged $5 for the call but as long as you tell them you've tried adding it twice on self-serve and it won't work, they wont charge you :)