Charged over $150 trying to activate my pre paid plan.....

  • 1
  • Question
  • Updated 3 years ago
  • Answered
Your website is insanely archaic. I just received my SIM and was trying to activate a pre paid plan. I went though all the steps and it said the charge was denied by my card issuer. I tried another time as there shouldn't be a problem with my CC. Didn't work. Went through the whole process again with a different card thinking maybe it was my mistake and it didn't activate again citing the same reason. Log into my banking and there's over $150 in charges over the 2 cards from my attempts. This is completely unacceptable. I tried to contact the call center and after way too many prompts and "heads up!"'s from the robot guy I find out it is closed. This situation needs to be rectified and I need to be justly compensated for my losses and frustration.
Photo of jeobrie

jeobrie

  • 90 Points 75 badge 2x thumb
  • disappointed

Posted 3 years ago

  • 1
Photo of Robert

Robert, Mobile Master

  • 103,644 Points 100k badge 2x thumb
Hello Jeobrie

The only way this can be fixed, is by calling Koodo. We can't help with account related problem on the community!

Hours of operation (local ET time):
  • Monday − Friday: 9am - 9pm
  • Saturday: 9am - 7pm
  • Sunday: 9am - 7pm
(Edited)
Photo of Veronica

Veronica

  • 3,528 Points 3k badge 2x thumb
Hi jeobrie!

Have you succeeded contacting us ? Has the issue been solved? 

Keep us posted!
Photo of jeobrie

jeobrie

  • 90 Points 75 badge 2x thumb
I tried to call yesterday and was on hold for longer than I had time to commit to. Will try again today.
Photo of Melissa

Melissa, Employee

  • 11,748 Points 10k badge 2x thumb
Hi Jeobrie, did you have the chance to speak with one of our customer service representatives yesterday?  
Photo of jeobrie

jeobrie

  • 90 Points 75 badge 2x thumb
Not yet. I called yesterday, it was a 45 minute wait. I had them call me back and I missed it as I was at work. They did call back later and I was able to answer, then put me on indefinite hold again while I waited for a rep. Its been 3 days and I still haven't been able to even speak to anyone. A real pain. Will try again today with a better outcome hopefully.
Photo of BobTheElectrician

BobTheElectrician

  • 61,576 Points 50k badge 2x thumb
You can try email:

https://secure.koodomobile.com/account/appmanager/support/contactus

Choose "social media". I know it doesn't make any sense, but I've had my fingers rapped a few times for suggesting this by the powers that be as it seems to be a "priority" channel.

Maybe consider activating with a prepaid card, for the time being, and then getting this sorted out later.

You deserve better.
(Edited)

This conversation is no longer open for comments or replies.