Charge problems after recent update?

  • 1
  • Question
  • Updated 10 months ago
  • (Edited)
2 weeks ago, My wife's and my  Galaxy5Neo were System Updated, we have experienced various problems since then, which I have already posted on.

 Last week Wed thru Friday her phone would not hold a charge going to 0% in an hour after recharging. Saturday early a.m. hers started working OK again and is still good today. However, today (noon) mine was charged to 100%, but was dead at 0% at 2 p.m,  (when I turned it on so a grand kid could play a game). Appears to be the same issue., but (research wise) it is early days for my unit. Both phones are 6 months old and have not had charging problems before.

 In the three days my wife had a problem it was consistent, 1 hr to lose charge and the typical 4 hrs to charge back to 100%. Then, repeating (just like deja vue all over again :) ) charge was back to 0 etc, etc.. Any ideas , comments would be appreciated.
Photo of stillgolfing

stillgolfing

  • 1,924 Points 1k badge 2x thumb

Posted 10 months ago

  • 1
Photo of Goran

Goran, Mobile Master

  • 96,868 Points 50k badge 2x thumb
You can attempt a factory reset to see if it fixes it. If not you might need to use the warranty. That's a severe break of something.
Photo of Dinh

Dinh, Mobile Master

  • 41,372 Points 20k badge 2x thumb
You could go into Settings --> (Or general)--> battery and see what is draining your battery? There might be some cue to the bleed.
Photo of Cory

Cory

  • 10,502 Points 10k badge 2x thumb
There is most likely an app or system resource "stuck" running and consuming your battery. Is your phone heating up? I would try a backup and then factory reset first.
Photo of stillgolfing

stillgolfing

  • 1,924 Points 1k badge 2x thumb
Thanks all! :) Will work my way thru ur suggestions.
Photo of rikkster

rikkster, Mobile Master

  • 68,252 Points 50k badge 2x thumb
OS updates tend to throw things out of whack with some devices. If you're referring to the Nougat update the S5 Neo received recently, by all means factory reset the device. (I did a factory reset right after the update). If you don't already have Samsung's Smart Switch software to backup the contents of your device, you can obtain the software from the link below.

See the heading on the right side of the page titled 'Get Samsung Smart Switch'
http://www.samsung.com/us/support/smart-switch-support/#!/