Change APN to disable Internet while enabling MMS on Samsung Ace 2

  • 3
  • Question
  • Updated 3 years ago
  • Answered
Archived and Closed

This conversation is no longer open for comments or replies and is no longer visible to community members.

Is there any way to change the APN settings on a galaxy Ace 2? I want to change the apn type from "internet + mms" to "mms" so that I can leave data on, receive picture messages, while not using the data for other internet uses. However, on my phone, the options are greyed out, and so I can't edit the apn settings at all. Does anyone have any ideas?
Photo of David Hopkins

David Hopkins

  • 202 Points 100 badge 2x thumb

Posted 5 years ago

  • 3
Photo of Chad Burr

Chad Burr, Mobile Master

  • 203,988 Points 100k badge 2x thumb
Using your Picture Messaging without allowing access to Mobile Data by anything else.

Brought to you by: The Koodo Mobile Masters with special thanks to Kid Android and Timo Tuokkola.
Can you send regular text messages but not picture messages?

SIM CARD BASED phones require a data connection in order to send those messages. So if you have data turned off, or blocked, these messages won't go through. "But wait" you say "My plan includes unlimited text and picture messaging. I want to use it but I don't want data because I feel it's too expensive (or whatever)". The Mobile Masters have your solution below.

You can enable data by navigating Settings / Wireless and networking / Mobile Network

Make sure 'use packet data' or 'enable data' is checked.

If you have data blocked by Koodo you'll need to unblock it. You'll have to call customer service to have the block removed. Follow the methods below to ensure data is only available to picture messaging.

Setting up A Koodo phone for MMS with no additional Data Access
FOR ANDROID DEVICES -=- for iphone 3GS see Note 2

First We need to do a little housekeeping. Navigate to your current messaging app and delete any picuture message you previously tried to send but have failed.

Next:

Navigate to Settings / Wireless controls / Mobile networks / access point names

METHOD 1.
Find the Koodo.sp Apn and tap it to open it. Some phones will allow you to edit this APN, for those phones which will not allow you to edit the default APN (I.E the Samsung Galaxy S2x), please skip to Method 2.

Tap APN type and change it so it reads only "mms" then tap the menu key and select save APN
once saved the 4g indicator should disappear. Please see: Note 1

METHOD 2

You'll be creating two APN's

Add the first apn (usually by hitting the menu key and tapping ADD NEW)

Note: in the example below please omit the spaces between the http: and the address This is done because some websites shorten URL's

Input the following settings (leaving designated fields blank):

APN NAME: Koodo (NoData)
APN: spp.koodo.com
Proxy server:
Port:
Username:
Password:
Server:
MMSC:
Proxy server:
Port:
MCC :
MNC :
APN type : default

For APN Type we use "default" for this example but if it doesn't work for you, go back and change it to "Internet"
Save this entry (usually by hitting the menu key and selecting SAVE)

Now create a Second APN using the following settings

APN Name: Koodo MMS ALLOW
APN: sp.koodo.com
Proxy server: 74.49.0.18
Port: 80
Username:
Password:
Server:
MMSC: http: //aliasredirect.net/proxy/koodo/mmsc
Proxy server: 74.49.0.18
Port: 80
MCC : 302
MNC : 220
APN type :mms

Now save this entry as you did the first.

On the list of available Access Point Names you'll notice three (or more) entries. Select the Koodo (NoDATA) APN and make it active (you'll notice you can not choose the Koodo MMS ALLOW entry)

Exit the APN menu.
Reboot the phone (Shut it off and turn it back on)
Turn off your WiFi
Open your browser and attempt to access any webpage other than Google (google is normally cached). You should get a message that the page cannot be displayed.

Note 1: (For Everyone to read)
You'll notice the 3G or 4G data indicator has disappeared leaving only the Signal strength indicator. IF YOU HAD PREVIOUSLY TRIED AND FAILED TO SEND PICTURES IT MAY TAKE A FEW MINUTES FOR THE INDICATOR TO DISAPPEAR. When you do send a picture the Data indicator will re-appear and the picture should be sent. The Same thing will happen when you get a picture message.

Note 2: (iPhone 3Gs)
Apparently the APN is not easly configurable. You may need to be Jail Broken and download an APP called "Tetherme" which will allow you to edit the APN as per Method 2 (Thanks DJMcPimpin's Sister)
Photo of Zaphod Beeblebrox

Zaphod Beeblebrox

  • 50,798 Points 50k badge 2x thumb
Pretty sure it was confirmed months ago....try not to comment on threads that have been answered months prior....

Unless you have useful information about this issue aside from confirmation...
Photo of DJ MCpimpin

DJ MCpimpin

  • 650 Points 500 badge 2x thumb
hi I used to have this working fine for the orginal OS for my Samsung S2X phone, now I upgraded a few days ago to jelly bean via the Keis and I had erased the apns so I had to re add, but since the re add I can not send or receive pictures, is there another setting that has changed in Jelly Bean I running 4.1.2 any help be great and they are the exact same settings above I have re checked 4 times
Photo of Lukasz Szlachta

Lukasz Szlachta

  • 100 Points 100 badge 2x thumb
I have a Samsung Galaxy S3 and this method does not work i still get data charges. I want data disabled but i want to use my unlimited mms that is included in my plan. I have complained several times that i keep getting charged for background app data while i send an mms and this cannot be turned off (i have set the limit background app data and only update via wifi options to be on) but the android os, gmail, and a few other stock apps you cannot delete still access data in the background even if i turn on data just to send the mms and turn it off once it is sent (the data charge appears as soon as i do this). On the Galaxy S3 it seems you cannot set up a way to use mms without data, Is there another method i could try to accomplish this?
Photo of No Way

No Way

  • 1,462 Points 1k badge 2x thumb
I think they do this on purpose to get that $5 extra for data used, even its just a few kbs. Ive been happy with koodo since I started Jul 2013, but this is getting out of hand. My wifes phone who has never been charged data now is because of some kbs being used somehow, even with the APN changed and she cant surf. She doesnt want or even use data, doesnt care. But she does like to MMS pictures without having to worry about it
Photo of Harish Paskaran

Harish Paskaran

  • 60 Points
Just wanted to let you know that your method works perfectly on my iPhone 6, allowing me to use MMS while blocking data use! Thanks! :)
Photo of David Hopkins

David Hopkins

  • 202 Points 100 badge 2x thumb
Yes, I have seen this post before, but as I said, the options that are used to edit and add APN's are grayed out and uneditable.
Photo of Chad Burr

Chad Burr, Mobile Master

  • 203,988 Points 100k badge 2x thumb
You can not add an apn on galaxy ace 2? Can someone confirm please..
Photo of B2theden

B2theden

  • 2,626 Points 2k badge 2x thumb
You can add Apn
Photo of Zaphod Beeblebrox

Zaphod Beeblebrox

  • 50,798 Points 50k badge 2x thumb
I'm sure that was answered....10 months ago.
Photo of Rocky Balboa

Rocky Balboa

  • 20,414 Points 20k badge 2x thumb
I just walked someone through adding a MMS apn so yes it's confirmed
Photo of David Hopkins

David Hopkins

  • 202 Points 100 badge 2x thumb
Here is a screenshot of the grayed options:
The grey line on the one option is me tapping it, and no response occuring besides acknowledging the touch.
Photo of David Hopkins

David Hopkins

  • 202 Points 100 badge 2x thumb
Koodo MMS and MMS are two attempts at tyour method 2. Note that there is no radio option beside the non-default APNs, and that I am long holding the one, and yet there is no option to change to the others as the active access point. There should at least be an unselected radio option.
Photo of Chad Burr

Chad Burr, Mobile Master

  • 203,988 Points 100k badge 2x thumb
Ok try hitting the menu key on the screen before this
Photo of Chad Burr

Chad Burr, Mobile Master

  • 203,988 Points 100k badge 2x thumb
I would suggest deleting your attempts and re reading the two APN'S described and try again
Photo of David Hopkins

David Hopkins

  • 202 Points 100 badge 2x thumb
The APNs were right, but I had to do a trick to be able to switch to them, from the locked-in default
Photo of David Hopkins

David Hopkins

  • 202 Points 100 badge 2x thumb
I got it, but it is a ridiculous solution. So, in the list of options when you press the menu key, there is a "reset to defaults" option. After you click that, the radio option by the default APN is unselected - allowing you to choose another one as long as you never select the default, at which point you have to reset it again and start over.
This is all to get around the restriction on editing or switching away from the default APN, and seems quite overkill - if someone doesn't know how to edit them, they will probably not be in those settings in the first place.
Thank you very much for your help Chad!
Photo of Chad Burr

Chad Burr, Mobile Master

  • 203,988 Points 100k badge 2x thumb
Ok so it does work for you then yes? Btw did you use default or Internet for the first apn?
Photo of Chad Burr

Chad Burr, Mobile Master

  • 203,988 Points 100k badge 2x thumb
I think the restriction is there to prevent newbies from accidentally editing themselves off tge network.
Photo of David Hopkins

David Hopkins

  • 202 Points 100 badge 2x thumb
But doesn't the "reset to defaults" option cover that well enough?
Photo of Chad Burr

Chad Burr, Mobile Master

  • 203,988 Points 100k badge 2x thumb
And a newbie might not find that option and it could result in a call to tech support
Photo of David Hopkins

David Hopkins

  • 202 Points 100 badge 2x thumb
Yeah, I guess. Anyway, thank you for your help!
Photo of David Hopkins

David Hopkins

  • 202 Points 100 badge 2x thumb
Yes, it works fine, on mobile data google does not work, but a mms sent to myself does. On my phone the types were a bit different. They were Internet, MMS, and DUP, in different variation. So, I have the "nodata" one set to Internet+DUP, and the mms one set to mms only. As far as I can tell, DUP is for dialup internet, but I left the option in there although I will never use it.
Photo of David Hopkins

David Hopkins

  • 202 Points 100 badge 2x thumb
and Koodo on the phone said that the APN settings are locked, which is what caused all of this
Photo of Timo Tuokkola

Timo Tuokkola, Mobile Master

  • 141,682 Points 100k badge 2x thumb
Just a bit of updated news on this workaround:
Based on testing, seems to work well on:
Galaxy S3, Galaxy S2x, Galaxy Ace 2x, Nexus S and HTC One V.

Works on original Galaxy Ace by simply changing apn type on default apn to MMS.

does not work on:
Optimus One, Optimus Black, Optimus Chat, Optimus L3 or INQ Cloud Touch, all of which seem to automatically switch back to the default (working) APN.
Photo of Rob Madro

Rob Madro

  • 80 Points 75 badge 2x thumb
Be warned that some applications circumvent these settings. I've had the 'Maps' application somehow manage to activate the 3G/4G connection, even though my browsers and other applications are blocked from internet access.

Shame on you Koodo. Your plans that included MMS and no data plan are as crooked as Mike Duffy's expense account dealings.
Photo of Kevin Dreger

Kevin Dreger

  • 60 Points
I experienced the same thing!! I'm trying to find a solution to the problem. I really don't want to have to manually turn off data when I leave a WiFi zone in fear of having apps do stupid updates even when I specifically turned auto-update OFF for apps. Why do some apps just update anyway? So frustrating. Is it too much to ask to have picture messaging and have no chance of apps doing background crap? I've done the APN changes, I've changed my auto-update settings... I've done it all, but still charges me a tiny amount of data.
Photo of Lukasz Szlachta

Lukasz Szlachta

  • 100 Points 100 badge 2x thumb
I wonder if there is grounds for a lawsuit here as the unlimited mms service you are paying for is not being delivered since it is impossible to use it without incurring charges and hence it is not unlimited and not free of charge like the contract (tab) with koodo you signed claims. I wonder if Breach of contract or misrepresentation law suit apply here since koodo knows about this issue and wont fix it.
Photo of No Way

No Way

  • 1,462 Points 1k badge 2x thumb
My wifes phone (samsung Ace II) for the first time in over a year somehow used data. From day one I changed the settings found on here so she didnt accidently surf or an app do something in the background, but still use picture messaging. I can see the above happening. None of us have data plans, yet have to find a work around to use their picture messaging so you dont use data.

They couldnt explain why it used data, it was so small but yet got charged $5
Photo of Adam Quinn

Adam Quinn

  • 70 Points
In the first of 2 APNs that I am creating from method #2 you say to leave the MCC and MNC fields blank. When I enter the add new access point screen those fields are by default 302 and 220 respectively. If I try to delete the entry and leave them blank, it won't let me save the APN unless there's a 3 digit number in the MCC and a 2-3 digit number in the MNC.

So I thought I would enter dummy numbers. I used 000 for the MCC and 111 for the MNC. I was able to save the APN but it didn't show up in the list. If I leave the numbers at 302 and 220 and save, it shows up in the list with the radial button as you described.

Any thoughts?
Photo of Chad Burr

Chad Burr, Mobile Master

  • 203,968 Points 100k badge 2x thumb
Those fields auto populated with the correct info. Leave em blank
Photo of Adam Quinn

Adam Quinn

  • 70 Points
Thank you, this worked just as you said. For other readers sake I was doing this on my daughter's Galaxy Ace 2x. I'll be monitoring the data usage of other apps to make sure no "non MMS" data is being transfered. If I think of it, I'll try to report back here in a couple of weeks to let others know if there are any apps my daughter downloaded that bypass this restriction, as Rob Madro implied.
Photo of Chad Burr

Chad Burr, Mobile Master

  • 203,968 Points 100k badge 2x thumb
For other readers; keep in mind this works primarily on Samsung devices, not koodo's fault, it's just how other phones handle changes to the apn.

So if this doesn't work for you, it may just be that it doesn't work for you.
Photo of Dylan Crawford

Dylan Crawford

  • 60 Points
I'm having a problem getting the radio buttons to display for the new APN (for just mms). It seems like if I change the APN type to Internet+mms, I can select it (and it works normally), but when I change it to just MMS, the radio button is gone.

ideas?

edit: I'm using an S2x running 4.0.4
Photo of Timo Tuokkola

Timo Tuokkola, Mobile Master

  • 139,892 Points 100k badge 2x thumb
That's the reason you have to setup 2 apn's. You can only select an apn if it is configured for internet access. Follow the directions as written and select the no data one.
so Do I use the spp.koodo.com for the No Data APN? I can't get it to stay on this APN it keeps going back to the orginal Koodo one
or is it sp.koodo.com?
Photo of Chad Burr

Chad Burr, Mobile Master

  • 203,968 Points 100k badge 2x thumb
As stated before. It doesnt work for every phone. Make sure it's spp.koodo.com and the type is isn't to default for this one.
Photo of No Way

No Way

  • 1,462 Points 1k badge 2x thumb
So the best way to test this would be to turn on data, disable wireless and try to surf. if a webpage doesnt come up data is disabled for that/ Then test picture messaging to see if it works
Photo of No Way

No Way

  • 1,462 Points 1k badge 2x thumb
Thanks for the info, on the Nokia Lumia 520 the setting to change is very simple. you can edit the exisitng APN in cellular settings, so I added the extra spp and tried to surf the web with no wireless. Nothing came through, same with email or anything else web based. But pictures work awesome.

Thanks for the tips
Photo of Shannon

Shannon

  • 70 Points
I have a Galaxy S2 X and I followed everything exactly as you posted it (I double and triple checked) Yet, I am still unable to receive picture messages. I can send them no problem. I don't even get an error message or alert saying I have a message waiting.

Bahh, I miss the simpler days when phones were just for calling/texting and all this stuff came already set up and ready to go on the phone.

Please help me!!
Thanks.
Photo of Timo Tuokkola

Timo Tuokkola, Mobile Master

  • 139,892 Points 100k badge 2x thumb
Sounds like there is a block in the network. Call tech support, they'll need to submit a trouble ticket to get the problem cleared.
Photo of Jonathan I

Jonathan I, Mobile Master

  • 114,344 Points 100k badge 2x thumb
I would try rebooting your phone and then have someone send you a pictue message again. You go into your messaging app, select the sender's conversation, and see if there's box that says "Download". You'll have to select that.

Also, in your messages app, press your soft menu key and go to settings. Look for the options "Auto-receive MMS" and make sure it's ticked.
Photo of No Way

No Way

  • 1,462 Points 1k badge 2x thumb
I have to set this up for my wife as she cant receive pictures (has data turned off on the phone right now) With my Nokia Lumia 520 I had to change a small setting, way easier than the Android way. I can get pictures from everyone except my one friend that has an Iphone, his says undeliverable when sending to me. Yet others can no problem. Wonder if Iphones send pictures over Internet, not MMS. Only thing I can think of
Photo of Shannon

Shannon

  • 70 Points
Thanks guys.

Jonathan; I've done 3 reboots and had my boyfriend try to send me pictures a couple times. I've even tried sending myself one. No luck. Absolutely nothing comes through.
Also, I double checked and "Auto retrieve MMS" is checked.

Thanks for trying though. And for the speedy responses :)
Greatly appreciated.
Photo of Leon Olszewski

Leon Olszewski

  • 60 Points
In case anyone is interested, I've been able to configure my Nokia Lumia 1020 (a Windows Phone 8 of course) to allow sending MMS but disallow non-MMS data usage by following these steps:

1. Navigate to Settings > cellular
2. Under "Data connection" select "on".
3. Under "Network selection" I was able to search for and select "Koodo" but I assume leaving it to automatic should be fine as well.
4. At the bottom you'll find a button that allows you to add or edit internet apn information. If you don't have internet apn information setup, the button will read "add internet apn". If you already have internet apn information setup here it will read "edit internet apn". If the button says "edit internet apn" press the button and delete all entered information. Otherwise continue to the next step.
5. At the bottom you'll also find a button that allows you to add or edit mms apn information. If you don't have mms apn information setup, the button will read "add mms apn". If you already have mms apn information setup here it will read "edit mms apn". In any case press the button and make sure the settings match those listed below (ignore the space in the MMSC value field):

APN: sp.koodo.com
User name:
Password:
WAP gateway (URL): 74.49.0.18
WAP gateway port: 80
MMSC (URL): http: //aliasredirect.net/proxy/koodo/mmsc
MMSC port: 80
Maximum MMS size:

6. When done editing the mms apn settings simply press the save icon. There is no need to re-enable any connections or restart the phone. You should be able to send "picture texts" now but doing other data-connection-oriented things like browsing the web should not work (as desired).

Note: To be able to receive picture texts I had to enable airplane mode and then disable it again. Just restarting the phone wasn't enough.
Photo of No Way

No Way

  • 1,462 Points 1k badge 2x thumb
So did this, and it works, but then it doesnt work. Followed the above, and was able to send and receive fine, then suddenly, the phone wasnt able to send or receive pictres. Called koodo and they re-pushed something on their end, and ti worked again. But then it was off and on with testing.

Sim card issue, you would think it would either work or not. Or maybe some pictures are to big and get :"stuck"
Photo of YG Su

YG Su

  • 60 Points
I was wondering in this instance. With all data other than MMS being blocked, I imagine we still get charged for the pay per use data. Am I correct. Since data is still being used but rather only for MMS, the files may be smaller but they still incur a charge. Or does the bill come out with no data charges?
Photo of No Way

No Way

  • 1,462 Points 1k badge 2x thumb
We have done the above for our three phones and we don't get charged data. It is still data but not the kind that they charge you for. Its unlimted data for MMS, or unlimted MMS messaging.
Photo of Ndola Mmba

Ndola Mmba

  • 180 Points 100 badge 2x thumb
Just in case this helps someone else...
I followed the "create a second APN" instructions above, but my Nexus 5 (kitkat) did not put a radio button next to the new APN, so I could not select it.
If I left the APN type field blank, I got the radio button, but I don't know if that allowed anything or everything.
If I put default,mms then it gave me a radio button, but I assume "default" means that apps could use "billable" data.
Finally I found that "mms,mms" gives me a radio button.

I don't know whether this is a kitkat bug, or what, but for now it seems to be working for MMS messages. I plan to keep an eye on this too see if other apps can use "billable" data with this APN chosen.
Photo of Chad Burr

Chad Burr, Mobile Master

  • 203,958 Points 100k badge 2x thumb
The second apn works in conjunction with the first apn and doesn't need to be selected thus it has no radio button.
Photo of Chad Burr

Chad Burr, Mobile Master

  • 203,958 Points 100k badge 2x thumb
The first apn is purposely incorrect. So when you send an Mms, the phone uses the second apn to send it, which is correct.

But, this method was later frowned upon because it doesn't work with every device
Photo of Ndola Mmba

Ndola Mmba

  • 180 Points 100 badge 2x thumb
Chad... thanks, didn't see your comments until now.

Can you explain how / why the second APN is "in conjunction with" the first APN?

In fact, I didn't follow your suggestions exactly, since I do (sometimes) want access to data, so I removed "default" from the pre-set Koodo APN and then created a second one with "default,mms", thinking that when I wanted data access, I could go in and select the other APN and get full data access.

But today looking at my booster usage summary I see that for some reason when I recieve an MMS I get usage charged to my data booster (which makes no sense to me whatsoever). I recall testing this the day I first did this setup and it seemed fine, but maybe the billing was delayed). So either something changed at Koodo HQ or I am doing something seriously wrong.
Photo of Zaphod Beeblebrox

Zaphod Beeblebrox

  • 50,798 Points 50k badge 2x thumb
Or something wasn't followed completely and due to incorrect settings, this situation happened. When you have unlimited messaging, any data for MMS is NOT chargeable. Only when the data "doorway" is open, is where additional data can leak through.
Photo of Chad Burr

Chad Burr, Mobile Master

  • 203,958 Points 100k badge 2x thumb
You added the word "default", which makes it use able as apn on on its own. Basically you told your phone to use this apn for anything that needs data.
Photo of DJ MCpimpin

DJ MCpimpin

  • 650 Points 500 badge 2x thumb
hi I used to have this working fine for the orginal OS for my Samsung S2X phone, now I upgraded a few days ago to jelly bean via the Keis and I had erased the apns so I had to re add, but since the re add I can not send or receive pictures, is there another setting that has changed in Jelly Bean I running 4.1.2 any help be great and they are the exact same settings above I have re checked 4 times

This conversation is no longer open for comments or replies.