cant send mms using blackberry

  • 1
  • Question
  • Updated 5 years ago
  • Answered
Archived and Closed

This conversation is no longer open for comments or replies and is no longer visible to community members. The community moderator provided the following reason for archiving: 1-866

I can't send pictures on my phone. I have a blackberry 9790 with a data plan. I remember to make sure that data is on before sending a message with a picture but it never works. I cant recieve pictures either. Does Anyone know how to fix this?? Its really frustrating. Any help is appreciated!
Photo of Alex Huynh

Alex Huynh

  • 104 Points 100 badge 2x thumb

Posted 5 years ago

  • 1
Photo of Paul Deschamps

Paul Deschamps, Mobile Master

  • 203,584 Points 100k badge 2x thumb
Your not on prepaid are you?

http://help.koodomobile.com/phone-tro...

If your on postpaid

You need to have data enabled.

2. Providing that your data is up and running, click on OPTIONS > MMS.

3. Make sure that both MULTIMEDIA RECEPTION and AUTOMATIC RETRIEVAL are set to ALWAYS.

4. Check both ALLOW DELIVERY CONFIRMATION and ALLOW READ CONFIRMATION boxes.

5. OPTIONAL: Remove all message filters. This enables you to receive MMS from people not in your device contacts. It opens you up to spam though, so you'll have to decide if this is worth it.

Remember to save the changes. You may need to pull the battery and restart your phone for the changes to take effect.
Photo of Timo Tuokkola

Timo Tuokkola, Mobile Master

  • 142,546 Points 100k badge 2x thumb
Go to options->device->advanced system settings->host routing table, press the menu button and choose register now. Then power the phone off and back on again. This registers the phone with the rim servers, which is required for data access on bb. Also, just to make sure, what is the data plan? It needs to either be a bb add on or the bb version of one of the promo plans, although that will apparently no longer be required with bb 10.
Photo of Myke

Myke

  • 45,090 Points 20k badge 2x thumb
To add onto Timo's, ensure that your firewall is turned off. This requires going into the security section of your Blackberry. The firewall can prevent text messages and picture messages from coming through.
Photo of Alex Huynh

Alex Huynh

  • 104 Points 100 badge 2x thumb
I'm not on prepaid, my plan is the following: "Canada Wide Double Promo30(BB)". It includes unlimited mms and sms along with 200mb of data. To all three of you, I have tried all of your suggestions but it hasn't solved anything. In the past, I've sent one picture by modifying the camera to save the image as medium (1024 x 768). But after that one picture, I've failed to send another successfully. I've done countless battery pulls and power offs as well. The firewall has not been enabled nor has it blocked any mms or sms. But to Timo, I recieved a confirmation email telling me i was registered with the rim server. Whenever I send the message, it displays the red clock continuously, as it tries to send the mms. I've also tried sending pictures to various other contacts (those with data plans of course) but have failed no less. I really don't understand what is going on, do you have any other suggestions?
Photo of Timo Tuokkola

Timo Tuokkola, Mobile Master

  • 142,546 Points 100k badge 2x thumb
That's about the limit of what can be done with no visibility into the system. It might be a network issue, or the service books might need to be repushed to the phone, but either would require a call to tech support.
Photo of Alex Huynh

Alex Huynh

  • 104 Points 100 badge 2x thumb
Alright, thank you so very much Timo! Your help was really appreciated! =)
Photo of Alex Huynh

Alex Huynh

  • 104 Points 100 badge 2x thumb
Would you happen to know Koodo's tech support contact information? All I can find is their number for customer service regarding changes to my account. Would I have to go to a kiosk?
Photo of Yannick

Yannick

  • 44,018 Points 20k badge 2x thumb
Hi Alex, to get in touch with our technical support, simply call 1-866-995-6636 from a landline and select option #6 :)
Photo of Silentbob

Silentbob

  • 90 Points 75 badge 2x thumb
Might have your fix. I had some SMS issues similar to this on my BlackBerry

Try go into Messages / Options / Text Messaging
There may be some filtering going on.
Turn off all filters and change "Network to Send Over" to Packet Switched Preferred
Photo of Jorden

Jorden, Mobile Master

  • 33,404 Points 20k badge 2x thumb
Welcome Silentbob!

While this is a good answer, the topic is 3 months old, and the op hasn't returned with new questions since Koodo responded. Please keep an eye on the dates of the post when replying.

This conversation is no longer open for comments or replies.