Can't receive MMS when data's off?

  • 3
  • Question
  • Updated 4 years ago
  • Answered
I disabled data on my plan so I wouldn't get charged accidentally, but now I can't receive picture messages (which are part of my plan). What gives? Is there any way around this?
Photo of Ryan Riahi

Ryan Riahi

  • 100 Points 100 badge 2x thumb

Posted 5 years ago

  • 3
Photo of Reena

Reena

  • 4,244 Points 4k badge 2x thumb
Hi Ryan
You will need to turn the data back on to receive the mms then turn the data back off.
Photo of John Burke

John Burke, Mobile Master

  • 71,346 Points 50k badge 2x thumb
Data needs to be enabled but depending on your device you can edit the APN.
Photo of Chad Burr

Chad Burr, Mobile Master

  • 203,988 Points 100k badge 2x thumb
after you remove the data block follow this tutorial to get picture messaging without using data.

Setting up A Koodo phone for MMS with no additional Data Access
FOR ANDROID DEVICES

Thanks and partial credit to John Burke

Navigate to Settings / Wireless controls / Mobile networks / access point names

You'll be creating two APN's

Add the first apn (usually by hitting the menu key and tapping ADD NEW)

Note: in the example below please omit the spaces between the http: and the address This is done because some websites shorten URL's

Input the following settings (leaving designated fields blank):

APN NAME: Koodo (NoData)
APN: sp.koodo.com
Proxy server:
Port:
Username:
Password:
Server:
MMSC:
Proxy server:
Port:
MCC :
MNC :
APN type :internet

Save this entry (usually by hitting the menu key and selecting SAVE)

Now create a Second APN using the following settings

APN Name: Koodo MMS ALLOW
APN: sp.koodo.com
Proxy server: 74.49.0.18
Port: 80
Username:
Password:
Server:
MMSC: http: //aliasredirect.net/proxy/koodo/mmsc
Proxy server: 74.49.0.18
Port: 80
MCC : 302
MNC : 220
APN type :mms

Now save this entry as you did the first.

On the list of available Access Point Names you'll notice three (or more) entries. Select the Koodo (NoDATA) apn and make it active (you'll notice you can not choose the Koodo MMS ALLOW entry)

Exit the APN menu.

You'll notice the 3G or 4G data indicator has disappeared leaving only the Signal strength indicator. IF YOU HAD PREVIOUSLY TRIED AND FAILED TO SEND PICTURES IT MAY TAKE A FEW MINUTES FOR THE INDICATOR TO DISAPPEAR. When you do send a picture the Data indicator will re-appear and the picture should be sent. Same when you get a picture message.
Photo of Ryan Riahi

Ryan Riahi

  • 100 Points 100 badge 2x thumb
Chad, you're a life saver. I'm currently using a dumbphone until my Nexus 4 arrives, but I'm sure your tut will come in handy once I'm back on Android! :)
Photo of Mark Richmond

Mark Richmond

  • 100 Points 100 badge 2x thumb
Chad this worked but will my apps etc still be using data and charging me for it? as it says messanging is using data, i have gone in and restricted the "background useage" of each app etc. I am using Nexus 4, love the phone, i had iphone 4 on Rogers, it ket mms come without data on but the company as a whole fell short
Photo of Mark Richmond

Mark Richmond

  • 100 Points 100 badge 2x thumb
I meant when I enter as you described it already had the 3 digits and as I entered the other info I deleted them but had to re enter as it wouldn't let me save without them
Photo of Mark Richmond

Mark Richmond

  • 100 Points 100 badge 2x thumb
yes it works but it still sends over data network right so there must be some charge. i had a talk text plan with Rogers and i could send pics and no charges as it was part of text
Photo of Mark Richmond

Mark Richmond

  • 100 Points 100 badge 2x thumb
and i had an apn for koodo already with basically all same except for the apn type, it said
APN TYPE default,supl,mms

whats the difference?
Photo of Chad Burr

Chad Burr, Mobile Master

  • 203,988 Points 100k badge 2x thumb
That field should say mms only if possible. It just tells the phone to use the APN for mms and look elsewhere for the Internett.

If you mean it sends mms data over the network that's normal and Koodo can see you're sending an mms and there's no charge for it.

Again I will reiterate that none of this is guaranteed and has only been proven effective on a hand full of devices.

In other words if you get data charges anyway, Koodo or myself isn't responsible. You are.
Photo of Marcus Fenix

Marcus Fenix

  • 15,752 Points 10k badge 2x thumb
If you connect to wifi, you can have mobile data turned on and send/receive pictures without additional charges. Applications will use the wifi connection as it will override the mobile data connection.
Photo of Mike W

Mike W

  • 82 Points 75 badge 2x thumb
I followed all the steps and rebooted. Nexus 4 4.4.2 rooted
Photo of Chad Burr

Chad Burr, Mobile Master

  • 203,988 Points 100k badge 2x thumb
Koodo nodata needs to be spp.koodo.com
Photo of Mike W

Mike W

  • 82 Points 75 badge 2x thumb
Changed it to that and still no luck. Tried toggling the "enable data"
Photo of Chad Burr

Chad Burr, Mobile Master

  • 203,988 Points 100k badge 2x thumb
Yeah this doesn't work with every phone and your data must be on to test this. Make sure the koodo nodata apn type is internet
Photo of Mike W

Mike W

  • 82 Points 75 badge 2x thumb
Yeah I tried internet and default. I remember using a ROM a while ago which allowed it while data was off. There has to be a root method to add that to other ROMs. Guess I'm stuck with using droid wall (can block data or wifi for certain apps) and flicking data on and off when I want to send an mms
Photo of Ayushi Pitchika

Ayushi Pitchika

  • 154 Points 100 badge 2x thumb
Hi Chad,
First of all thanks for such detailed and easy to understand instructions for the setting up of the APNs. May I ask what exactly this does though? I understand we are editing the APN so that background data leakage is minimized right? But I still do need to keep the Data permanently on is that right? And what about when I genuinely need to use the data on the run for say Google maps. Will this in any way block its access then? I'd love to understand more about what exactly we are trying to achieve here.Thanks!
Photo of Chad Burr

Chad Burr, Mobile Master

  • 203,988 Points 100k badge 2x thumb
Hi Ayushi, what this does is block data for anything other than MMS. This is for those who don't want to use data at all for anything else. If you're planning to use maps and other apps which require data then this won't work for you. :-(

Unfortunately this doesn't work for everyone. A staggering number of devices actually revert to the default settings even after these settings are modified. For that reason, I don't push people to this thread anymore.

I hope I've answered your question.
Photo of M

M

  • 150 Points 100 badge 2x thumb
I have a Koodo phone and this is the settings that came with the phone. I can't send MMS. Do I go to a Koodo shop or is there a number to call?
Photo of M

M

  • 150 Points 100 badge 2x thumb
Other pages
Photo of M

M

  • 150 Points 100 badge 2x thumb
Other 3/3
Photo of M

M

  • 150 Points 100 badge 2x thumb
And my phone is

This conversation is no longer open for comments or replies.