can't connect to home wi-fi on galaxy ace?

  • 4
  • Question
  • Updated 5 years ago
  • Answered
so i just got the galaxy ace 2 x and everything worked fine until i tried to connect with my home network. i've chosen the network and typed in the password repeatedly and i cannot click the connect option. i've factory reset the phone and nothing has changed... can't just look for open networks and use my data all the time. help?
Photo of Kat

Kat

  • 120 Points 100 badge 2x thumb

Posted 5 years ago

  • 4
Photo of Timo Tuokkola

Timo Tuokkola, Mobile Master

  • 139,982 Points 100k badge 2x thumb
did you try rebooting the router? (do it even if other devices are connecting fine)
Photo of Gerard Mascarenhas

Gerard Mascarenhas

  • 102 Points 100 badge 2x thumb
I have had a fine time with my Internet until a few days ago. The same phone, I reconnected. It says I am connected but I can't use my Internet. Other devices in my house that require Internet works fine. Whenever, let's say I use YouTube. It tries to load up but you see the the circle spinning. i disconnected and reconnected my router. It still doesn't work. When I go to the Wi-Fi page it says Scanning at the top right corner almost every time. I even tried by turning off Wi-Fi and turning on Wi-Fi. It still wouldn't work. And lately, when I turn on my Wi-Fi it says turning on and turning off and the cycle repeats over and over again.
Photo of Gerard Mascarenhas

Gerard Mascarenhas

  • 102 Points 100 badge 2x thumb
Oh and I've also had to restart my phone so many times. Still no changes whatsoever. Even if I sit right beside the router.
Photo of rikkster

rikkster, Mobile Master

  • 66,988 Points 50k badge 2x thumb
Try the method I posted: http://gsfn.us/t/4928t
Photo of Gerard Mascarenhas

Gerard Mascarenhas

  • 102 Points 100 badge 2x thumb
Thanks for replying back rikkster but my case worsened and I don't know if it will still apply so I'll tell you my current status.

When I open up Wi-Fi it says Notify Me and Add Networks. This is when it's off. When it's turning on all it says is Turning on. Even when the the bar that slides at the top right, slides to the right to turn on it doesn't work and the bar slides to the left and still says turning on.

In Advanced these are Gray:Network Notifications, MAC Address and IP address. In White are: Keep Wi-Fi on during sleep and check for Internet service. My IP address says unavailable.

I am a little ticked off because I pressed backspace and it erased everything I had written so neatly before. Oh and besides that my phone turned off and restarted somewhere when I was checking and writing. My phone restarting on it's own has been occurring frequently lately
Photo of Gerard Mascarenhas

Gerard Mascarenhas

  • 102 Points 100 badge 2x thumb
My phone was actually sent to repairs. It came back a week ago but found out my battery died. So I needed to get a new battery and that took up another week and a half. So I finally got my battery back today and I am still facing the problems after a reset because all my stuff is gone. Oh and by the way, this incident happened the day before you replied.
Photo of rikkster

rikkster, Mobile Master

  • 66,936 Points 50k badge 2x thumb
Did you get any sort of explanation as to what was done to your phone repair-wise or what the problem may have been?
Photo of Gerard Mascarenhas

Gerard Mascarenhas

  • 102 Points 100 badge 2x thumb
The problem was that my phone wouldn't turn on and I told them about the Wi-Fi issue as well but the guy just wrote down that it wouldn't turn on.
Photo of Chad Burr

Chad Burr, Mobile Master

  • 203,968 Points 100k badge 2x thumb
Contact service right away and tell them you're still having this issue.
Photo of rikkster

rikkster, Mobile Master

  • 66,936 Points 50k badge 2x thumb
Chad is correct and it would have been my next suggestion as well. If the device is still doing the same thing before you sent it off for repair and is continuing to show the same signs after repair, basically nothing has been repaired.
Photo of Daniel Kim

Daniel Kim, Mobile Master

  • 34,736 Points 20k badge 2x thumb
Yeah i agree, try putting your phone into airplane mode then turn airplane off and see if it detects your wifi network. then try rebooting and if that still doesnt work i guess a factory reset will be necessary. make sure to backup your contacts and stuff though. Hope it works! :)
Photo of rikkster

rikkster, Mobile Master

  • 66,936 Points 50k badge 2x thumb
I don't see how that would work, given that Gerard can't turn on Wi-Fi to start with.

This conversation is no longer open for comments or replies.