Can't send picture messages from my S4, even with data enabled and on a data plan.

  • 1
  • Question
  • Updated 11 months ago
  • Answered
I recently (April 2015) bought a Samsung Galaxy S4 on a Koodo plan and I haven't been able to send text messages with picture attachments.  I am on a data plan and have data enabled but it just shows the little 'loading' circle animation under the text message for an indefinite amount of time when I try to send it.

Any ideas?
Photo of Jim Legs

Jim Legs

  • 80 Points 75 badge 2x thumb
  • Frustrated

Posted 3 years ago

  • 1
Photo of Mathieu

Mathieu, Mobile Master

  • 60,848 Points 50k badge 2x thumb
Check the APN settings and make sure they are correct:
http://help.koodomobile.com/plans-add-ons-data-and-other-services/data/how-do-i-setup-data-on-my-non...

Are you able to access websites using your data connection? Please make sure you are actually using your cellular network and not Wi-Fi. Also, did you maybe have a data block added to your account? You can check that in self-serve under the add-on tab
Photo of Sarah Jane

Sarah Jane

  • 270 Points 250 badge 2x thumb
Are you able to send regular texts ? I was having issues sending texts yestetday and same today. It seemed to work when I left my house but when I'm back I still can't send or receive anything. If it's towers than koodo needs to get their ass in gear as this is quite annoying.
Photo of sandra mackinnon

sandra mackinnon

  • 180 Points 100 badge 2x thumb
I have the same problem.  I can not receive picture text even with my data on.  HELP
Photo of BobTheElectrician

BobTheElectrician

  • 67,286 Points 50k badge 2x thumb
In your mobile network settings, try changing network type to WCDMA/GSM without the LTE then restart the phone.
Photo of Jan Hope

Jan Hope

  • 4,356 Points 4k badge 2x thumb
Hi Sandra is you phone Galaxy s4, as well?