Can't send picture messages

  • 1
  • Question
  • Updated 2 months ago
I have a Google Pixel XL and it says that sending 'premium texts and picture messages' are part of my plan. I can receive pictures, but when I try to send it, it says "Not sent. Tap to try again". I've had this phone for over a year now so I know it has nothing to do with having to reset my phone or screw around in my settings (as far as I know). My brother has the exact same phone and he has no issue sending picture messages and gifs my way. I also had a Samsung phone with the same problem.
Photo of Frodo Baggings

Frodo Baggings

  • 122 Points 100 badge 2x thumb
  • frustrated

Posted 2 months ago

  • 1
Photo of Goran

Goran, Mobile Master

  • 97,868 Points 50k badge 2x thumb
You could try resetting your APN. If that doesn't work then you can send a private message to Koodo via Facebook Messenger or DM via Twitter to see if there's some backend problem for you.
Photo of Frodo Baggings

Frodo Baggings

  • 122 Points 100 badge 2x thumb
Didn't know they had a Facebook. Thanks!
Photo of Dinh

Dinh, Mobile Master

  • 42,336 Points 20k badge 2x thumb
hi Frodo,
Have you enabled Mobile data in your phone?. MMS requires it enabled. I would also suggest you do a reset of network settings in your phone.

If you check APN, here is the link to APN settings: https://www.koodomobile.com/help/setting-data-your-non-koodo-phone
(Edited)
Photo of Elaine B

Elaine B

  • 80 Points 75 badge 2x thumb
Thanks for your replies. I’ve been trying to figure it out for awhile. Even at home with my wifi it doesn’t send photos from SMS /MMS.
Photo of David

David, Mobile Master

  • 93,850 Points 50k badge 2x thumb
You can't send SMS / MMS through Wi-Fi. If you have Wi-Fi on while sending MMS, you reduce the likelihood of collateral data being consumed on your cellular data plan, but you would still need to turn on your cellular data to send or receive the MMS.
Photo of David

David, Mobile Master

  • 93,850 Points 50k badge 2x thumb
The Data block is $2 per month.
Photo of Dinh

Dinh, Mobile Master

  • 42,336 Points 20k badge 2x thumb
@Elaine B: you could add the data block add-on in your selfserve, View rate plan --> manage add-on. You should see the $2/month "Data Block w/ Pic Msg"

After getting that, you could turn on your cellular data and send/receive MMS without any fear of data overage.

Also, I assumed you are a postpaid (monthly customer). If you are a prepaid customer, you don't have to worry about data consumption (if you don't have any), just turn the mobile data (cellular data) on.
Photo of Dennis

Dennis, Mobile Master

  • 196,866 Points 100k badge 2x thumb
To clarify a bit.
iMessage uses pure data and will work with wifi.

MMS uses only cellular data that koodo includes in your plan. It won't work on wifi. But if you turn on data, background data may be used. That is what the data block is for.