Can't send MMS messages but can receive them.

  • 2
  • Question
  • Updated 2 years ago
  • Answered
I have been using Koodo for a couple months now but I don't do much data or image messaging.

However this week I recieved an image from a friend via text and I wished to send it to someone else. I saved the image on my device and tried to send it but it either never sends or gives me an error stating no APN specified despite the fact that I have one set and can receive mms and data works fine. I have tried sending to multiple people multiple images as well and can not send any mms.

 i have searched the koodo forums and the rest of the internet but I am unable to find a solution. I have tried a multitude of different APN settings for koodo to no avail.

I have a SONIM XP7 smartphone with ANDROID 4.4.4 which is the latest software available for the device. I have tried changing the APN settings and resetting my phone to see if that would fix it and that is no help.
Photo of Dylan

Dylan

  • 80 Points 75 badge 2x thumb

Posted 2 years ago

  • 2
Photo of rikkster

rikkster, Mobile Master

  • 67,104 Points 50k badge 2x thumb
Hi Dylan,

Try resetting the APN to default. Go to: Settings> Wireless & networks > Mobile networks > Access point names - tap the menu icon, (three dots in upper right hand corner of screen) and select Reset to default. I'm not familiar with the Sonim XP7, the path to this setting may differ slightly.

If the above doesn't yield any results, under the APN type, enter: default, mms or enter an asterisk. Save your settings. A reboot is not required.