Can't recieve SMS messages on new iPhone 5c

  • 1
  • Question
  • Updated 3 years ago
  • Answered
Hi, I upgraded my phone to an iPhone 5c earlier this week, but I've been having an issue where other iPhone users can receive my SMS messages when I'm not on data/wifi but I cannot receive their text messages back (I get the backlog of messages when I turn wifi or data back on). iMessage works fine when I have a wifi/data connection. I've tried everything that I could find online - deleting the message threads, restarting, resetting network settings, deleting the contact entirely and creating them again and even all the fixes associated with iMessage and my appleid. Nothing is working. The only fix I've found is asking the person I'm texting to push through and manually "send as text" on their end. I've had the people I text the most check all their settings and do everything I've done in order to try and resolve this on their end as well but it's just not working no matter what. The strange thing is the day or two after getting this new phone, text messages were sending and receiving just fine... Any idea what I can do to fix this?
Photo of Stacey Mc

Stacey Mc

  • 82 Points 75 badge 2x thumb
  • frustrated

Posted 3 years ago

  • 1
Photo of Robert

Robert, Mobile Master

  • 105,020 Points 100k badge 2x thumb
Because you switch your data on/off all the time it makes the other phone not know when your iMessage is active and when it isn't. A simple fix to this would be disabling iMessage OR ask the person on the other end to activate "send as SMS" when iMessage does not work.
Photo of David

David, Mobile Master

  • 91,276 Points 50k badge 2x thumb
An even simpler fix would be to leave data on, and prevent all but the most necessary apps to access cellular data!
Photo of Big Al

Big Al

  • 200 Points 100 badge 2x thumb
How do I do what u just suggested? Leave data on but I only want it on for the texts and nothing else?
Photo of David

David, Mobile Master

  • 91,276 Points 50k badge 2x thumb
Settings > Cellular, then turn off the apps you want not to connect to cellular data.
Photo of Matthew Hill

Matthew Hill

  • 3,102 Points 3k badge 2x thumb
I believe if you turn iMessage completely off this issue should be resolved.

Go to settings > Messages > Turn off iMessage.

when iMessage is on, other iphones assume you have Data, and the message is sent as an iMessage which would be why you wouldn't get it.

When iMessage is turned off, other iPhones should see that its off and send the message as a text.
Photo of Stacey Mc

Stacey Mc

  • 82 Points 75 badge 2x thumb
Thanks for the replies.
Photo of Harish Paskaran

Harish Paskaran

  • 90 Points 75 badge 2x thumb
As the fine folks have replied above, this is not an issue on Koodo's end, but rather an issue with the way your phone handles the transition between iMessage and SMS texts.

When you turn off your data, your friends with iPhones will not be able to send iMessages to you and their phones won't know what to do.

By default, in the Messages portion of Settings, Apple has set the "Send as SMS" option to the off position. This makes it so when your iMessages fail to send, they won't automatically send as SMS instead.

What you want is the opposite effect! Make sure you turn this option on and make sure your friends do the same with their iPhones to avoid this issue. You could also disable iMessage if you so wish to eliminate the issue altogether. The decision is up to you.

Here's a screenshot from my phone highlighting the option: 

This conversation is no longer open for comments or replies.