Can't login/register for self-serve

  • 1
  • Question
  • Updated 7 months ago
  • Answered
I bought the phone from a WOW! mobile booth a couple months ago but never got the chance to register for self-serve. Now when I try to register it sends me the email and I click the link but the page just tells me that I can't register and it might already be registered. I thought maybe I had registered the phone at the store I bought it at so I tried to log in but it won't let me reset my password, saying my credentials don't match but I've gone through the "forgot my email" system and that's the email I've been trying to use to recover my password and the last name is the same last name on my agreement so now I just don't know what to do.
Photo of Bryce isNice

Bryce isNice

  • 70 Points
  • frustrated

Posted 7 months ago

  • 1
Photo of Dinh

Dinh, Mobile Master

  • 33,004 Points 20k badge 2x thumb
When you bought the phone,they would send you an email to register, that email is normally expired in 1,2 days. From your story, I think your account in selfserve haven't been activated. You properly have to call koodo or send message through Facebook to ask them to send another mail for activation for you.
Photo of Bernard

Bernard, Official Rep

  • 75,648 Points 50k badge 2x thumb
@Azure123, just a heads up, the email we send at activation is good for at least 30 days.
Photo of Dinh

Dinh, Mobile Master

  • 33,004 Points 20k badge 2x thumb
Thanks, good to know :) the koodo store clerks, told me to register that night or the link would die. He might want to make sure I didn't forget. lol. That was why I thought it should have lasted for 24 hours or 48 at most.
(Edited)
Photo of Sophia

Sophia, Mobile Master

  • 141,558 Points 100k badge 2x thumb
Sounds like you are in a bit of a loop here, Bryce :) Best way to solve this is probably to send Koodo a private message on Facebook, they'll make sure you can log into self service in no time.
Photo of Bernard

Bernard, Official Rep

  • 75,648 Points 50k badge 2x thumb
@Bryce, I see an active account registered and it seems you were able to log in the middle of August. Now, it's not your name that is on the account though so that maybe part of the issue.