Can't get setup on self serve

  • 2
  • Question
  • Updated 11 months ago
  • Answered
Setup up an account, received email to confirm account, clicked on link, got forbidden 403 error.
Tried a different network (assumed that firewall had caused the problem) got sent to a page saying, this email has already been confirmed login, tried to login, forbidden error again.
Trying just to log directly in, taken to page saying this account has been linked to another email already and is waiting for confirmation, back to home page.
And all this within 5 minutes of first time signing up.
Photo of Jordan


  • 90 Points 75 badge 2x thumb

Posted 11 months ago

  • 2
Photo of Robert

Robert, Mobile Master

  • 101,484 Points 100k badge 2x thumb
Hello Jordan, 

Have you signed up with the same e-mail you gave when you registered your account? 
Photo of Jordan


  • 90 Points 75 badge 2x thumb
If you mean the same email i signed up for with this forum, then yes.
if you mean the same email i registered and tried signing into self service with, then also yes. One email for everything.
Photo of Bernard

Bernard, Official Rep

  • 71,332 Points 50k badge 2x thumb
Jodan, can you pls send us a private message on Facebook and will look at your account and help you out.