Can't connect to YouTube or Google maps despite full bars LTE and every other app working

  • 1
  • Question
  • Updated 3 years ago
  • Answered
I have a Nexus 5 Android 4.4.4 and my phone says I have full bars and LTE. Web and every other app works (including gmail), but YouTube and Google Maps cannot connect. All over the city of London and all times of day/week. These are my most important apps. I have 3gb (which is already ridiculously low compared to T-Mobile's unlimited US+Canada plan
Photo of Colin Lernell

Colin Lernell

  • 70 Points

Posted 3 years ago

  • 1
Photo of Daniel Kim

Daniel Kim, Mobile Master

  • 34,736 Points 20k badge 2x thumb
Try closing those two apps, (press that icon on the bottom right) then swipe the apps away and try re-opening them.
Photo of BobTheElectrician

BobTheElectrician

  • 61,868 Points 50k badge 2x thumb
To re-awaken a stalled connection, data or voice, go into airplane mode for 10 seconds, and then come back out of it. I sometimes have to do this in marginal areas like my rural home.
Photo of Spence

Spence

  • 8,354 Points 5k badge 2x thumb
And power off and restart phone if haven't done that yet.
Photo of Matt Gittleman

Matt Gittleman

  • 80 Points 75 badge 2x thumb
Hi, This has been happening for 2 weeks and I have already done all of the above.
The connection is fine for every other app or service on my phone except these 2 apps. I have even uninstalled/reinstalled them.
Photo of Veronica

Veronica

  • 3,528 Points 3k badge 2x thumb
Hey there!

@Colin Have the suggestions mentioned here helped ?

@ Colin, @ Samantha  Are the apps running OK on WI-FI? If so, can you check if their background data is restricted? Go to Settings, tap Data usage, choose the app you’d like to see the details for, make sure Restrict background data is unchecked.

Let us know how this worked out for you!
(Edited)

This conversation is no longer open for comments or replies.