Cant connect to koodo network xperia U

  • 1
  • Question
  • Updated 3 years ago
  • Answered
Hello,
I have a new unlocked xperia U.  Here what it say on the box:
GSM/GPRS/EDGE 850/900/1800/1900 & UMTS HSPA Bands 1/8
But when I put my sim card in, it does not connect to koodo network.  I'm I missing something?
Photo of Jocelyn Gagné

Jocelyn Gagné

  • 100 Points 100 badge 2x thumb

Posted 3 years ago

  • 1
Photo of Spence

Spence

  • 8,354 Points 5k badge 2x thumb
This device will only work on 3G.
Try setting your preferred networks to HSPA only or wcdma only
Koodo does not have 2G or Edge
Photo of Taylor Upshaw

Taylor Upshaw

  • 1,856 Points 1k badge 2x thumb
Still trying to fully understand how this works myself but I'm pretty sure you need both 1900 and 2100 bands to work with Koodo. Looks like this phone is missing the 2100 band
Photo of Spence

Spence

  • 8,354 Points 5k badge 2x thumb
You need 850/1900 for 3G network

LTE uses 1700/2100
Photo of Taylor Upshaw

Taylor Upshaw

  • 1,856 Points 1k badge 2x thumb
for most devices do you have to manually select the 3G network or will it automatically detect connect?
Photo of BobTheElectrician

BobTheElectrician

  • 61,736 Points 50k badge 2x thumb
Photo of Spence

Spence

  • 8,354 Points 5k badge 2x thumb
This phone came out over 3 years ago,  under powered for 2015
Photo of Spence

Spence

  • 8,354 Points 5k badge 2x thumb
Jocelyn,  are you getting an error of any sort about the SIM ?
ie: sim not detected , or enter carrier code , or no service
Photo of Jocelyn Gagné

Jocelyn Gagné

  • 100 Points 100 badge 2x thumb
Ha!  thank you for reminding me that the phone is old!  But I like small phone and they are today bigger and bigger!
Well, I do get that sim error, depending on the menu I'm looking at.  When I try to manually connect to a network, I can sometime see a network names EXT 2G
Photo of Spence

Spence

  • 8,354 Points 5k badge 2x thumb
2G will not work on Koodo.
Can you find preferred network in your settings
Photo of Jocelyn Gagné

Jocelyn Gagné

  • 100 Points 100 badge 2x thumb
I can see there either GSM, WCDMA, or both
Photo of Spence

Spence

  • 8,354 Points 5k badge 2x thumb
It should work on WCDMA only
Photo of Jocelyn Gagné

Jocelyn Gagné

  • 100 Points 100 badge 2x thumb
well, my old A341 connect right away to kodoo...  Maybe there's a setting somewhere I'm missing.  Thanks for your help

This conversation is no longer open for comments or replies.