Cannot shut my mobile data off...ever

  • 1
  • Question
  • Updated 2 weeks ago
I've had an unlocked Samsung Galaxy s5 from verizon for about a year. Initially I was on telus and recently migrated to koodo. For the entire time I have owned the phone, my mobile data is always on even if it is crossed out and turned off. I can uncheck mobile data in settings, black out mobile data in the short cut menu, no wifi, but I always have Internet access. Currently I am set on global. Any suggestions how I can get data off? Thanks.
Photo of Lee Woodward

Lee Woodward

  • 130 Points 100 badge 2x thumb

Posted 2 weeks ago

  • 1
Photo of Dinh

Dinh, Mobile Master

  • 41,904 Points 20k badge 2x thumb
hi Lee,
Which option was available to you in the data option? if you turned of the mobile data but still could access the internet, there could be something wrong with the firmware.

Can you try to reset the APN? (Settings --> Network connections --> more network --> Mobile network --> Access Point Names --> Delete the current APN information there.
Photo of rikkster

rikkster, Mobile Master

  • 68,350 Points 50k badge 2x thumb
Try setting the network mode to LTE/GSM/UMTS. Go to:  Settings > More networks - select Mobile networks > tap Network Mode and and select LTE/GSM/UMTS. If running Android 6 or higher, reset network settings by going to: Settings > Backup & Reset and look for Network Settings Reset and follow the prompts. After you've completed these steps, see if you can disable mobile data.

Another option, check APN settings. Go to: Settings > Scroll to 'NETWORK CONNECTIONS,'  then tap More networks. Tap Mobile networks - select Access Point Names (APN). If possible, delete any other APN's other than Koodo. Verify all information is entered correctly using Koodo's APN setting chart below. Koodo's APN type field can be left blank or you can type one of the following protocols; 'default' or 'internet + mms' exactly as typed without quotation marks.

Photo of Lee Woodward

Lee Woodward

  • 130 Points 100 badge 2x thumb
Thanks for the help guys. Here's some answers.

1. I am running Android 6.0.1.
2. Global is the only network mode that works. If I toggle to either the two CDMA or GSM options I get the x in the signal bar and it asks to automatically go back to global.
3. I could only delete the previous telus and kodoo access points. The verizon access point is greyed out if I ask to go back to default.
4. The kodoo''s apn's settings are exactly as described. The bearer option is lte and the apn protocol ipv4.
5. The same problem happened when I was with telus immediately when I bought the phone a year ago in the states. So it is not unique to Kodoo.
Photo of Mats

Mats

  • 21,544 Points 20k badge 2x thumb
Have you tried resetting your network settings as Rickster mentioned?

Does your Koodo plan include data or no data? If you are able to edit APN settings to disable data you would have to edit again to get data working which might be a hassle for you if you want to use data.
Photo of Lee Woodward

Lee Woodward

  • 130 Points 100 badge 2x thumb
Thanks Rickster and Mats!!! Resetting the network settings worked somehow. I have to re-enter all my WiFi passwords but that is minimal compared to always having my data on. Now when I toggle mobile data off, it is actually off. Thanks again guys. Really appreciate the help!
Photo of Lee Woodward

Lee Woodward

  • 130 Points 100 badge 2x thumb
HI Rickster. Now I cannot send or receive an mms text message. Mobile is toggled on. Global is the only network mode that works. Koodo APN settings typed in exactly as Rickster suggested above. Any thoughts?
Photo of rikkster

rikkster, Mobile Master

  • 68,314 Points 50k badge 2x thumb
Hi Lee. The 'APN type' field is usually left blank, but in some instances the APN type must be specified. Enter only one APN type or a grouping separated by commas. For example, you can use 'default' or 'internet + mms' or default, mms (minus quotation marks). 

Another option is to enter just an asterisk (*) minus the parentheses ( ). This tells your device to use the same APN configuration for all types of data. Let us know if this resolves the MMS send/receive issue.
Photo of Allan

Allan, Mobile Master

  • 62,624 Points 50k badge 2x thumb
So if you turn both your wifi and data off you can still load a web page?
Photo of Lee Woodward

Lee Woodward

  • 130 Points 100 badge 2x thumb
Correct.
Photo of Dennis

Dennis, Mobile Master

  • 196,080 Points 100k badge 2x thumb
What happen when you connect to a wifi that doesnt work (or requires signing in/ToS but you dont register), does a web page still load?
Photo of Dinh

Dinh, Mobile Master

  • 41,904 Points 20k badge 2x thumb
@Lee: can you edit the APN settings. You could try to delete the APN "sp.koodo.com" and see if it can stop your data.