Cannot send or receive mms

  • 1
  • Question
  • Updated 3 months ago
  • Answered
I have recently got a new Samsung galaxy s7 and have noticed that sending or receiving mms does not work. I have set up the apn settings already, I have also tried resetting network settings as well. Tried turning flight mode on and off, Tried resetting my phone as well :/ nothing seems to work. Please help.
(Yes my mobile data is on and working)
Photo of Rose Lam

Rose Lam

  • 130 Points 100 badge 2x thumb

Posted 1 year ago

  • 1
Photo of Robert

Robert, Mobile Master

  • 107,602 Points 100k badge 2x thumb
What are your APN settings?
Photo of Rose Lam

Rose Lam

  • 130 Points 100 badge 2x thumb
Photo of Erwin

Erwin

  • 23,576 Points 20k badge 2x thumb

Hey Rose,

Are you trying to send/receive MMS with one phone number?

Photo of Rose Lam

Rose Lam

  • 130 Points 100 badge 2x thumb
Yes, one phone number
Photo of Erwin

Erwin

  • 23,576 Points 20k badge 2x thumb
Could you try sending another MMS to another phone number to test? It could be an issue with the other phone number.
Photo of Rose Lam

Rose Lam

  • 130 Points 100 badge 2x thumb
Doesn't work :/ Tried with 3 different numbers
Photo of Erwin

Erwin

  • 23,576 Points 20k badge 2x thumb
By any chance, do you have anyone near you who is also with Koodo and uses a nano sim? I recommend troubleshooting by inserting their sim to your phone and your sim to their phone, send MMS. This will help us determine if it is a hardware issue or a sim/network issue.

If you done have anyone else who uses the same sim and in the same network, I recommend bring your phone to a Koodo Shop.
Photo of Rose Lam

Rose Lam

  • 130 Points 100 badge 2x thumb
I will try that and follow up, thanks!
Photo of Allan

Allan, Mobile Master

  • 62,774 Points 50k badge 2x thumb
Under APN type use: default, mms
Photo of Rose Lam

Rose Lam

  • 130 Points 100 badge 2x thumb
Did not work :/
Photo of Allan

Allan, Mobile Master

  • 62,774 Points 50k badge 2x thumb
And leave both proxy and port blank.
Photo of Robert

Robert, Mobile Master

  • 107,602 Points 100k badge 2x thumb
Here's mine, we have MMS proxy that's different
(Edited)
Photo of Rose Lam

Rose Lam

  • 130 Points 100 badge 2x thumb
Doesn't work :/
Photo of Dennis

Dennis, Mobile Master

  • 196,672 Points 100k badge 2x thumb
Make sure you data is enabled and you dont have data block.

FYI, Wifi will not work for MMS 
Photo of Sunspot

Sunspot

  • 160 Points 100 badge 2x thumb
I have had the same problem for the last four months since I changed to Koodo and I tried everything listed in this thread, but nothing worked.
Now I finally found a solution, and it is pretty simple. In APN Type mark default,mms,supl save it and reboot the device.
I hope that will help someone as it helped me!