Can you send picture messages for free on Nexus 5 without a Data plan?

  • 1
  • Question
  • Updated 3 years ago
  • Answered
Hi! I was just wondering if there was a way to send picture messages without paying for data! I do not have a data plan, but with my samsung S2 I changed the APNs (koodo no data, and koodo mms allow) and I am trying to do the same for my Nexus 5, but it is not working! Any suggestions?
Photo of Jay

Jay

  • 152 Points 100 badge 2x thumb

Posted 4 years ago

  • 1
Photo of Ahmad

Ahmad

  • 96,102 Points 50k badge 2x thumb
In order to help us set up your Nexus 5 to do that, you are going to have to be a lot more specific than "but its not working". What part isn't working? Where does it go wrong? Details please :)
Photo of BobTheElectrician

BobTheElectrician

  • 67,204 Points 50k badge 2x thumb
To the best of my understanding by reading the community, MMS (picture messaging) DOES require mobile data, not just wifi connection, but supposedly you will not be charged for it.

So enable data on your phone Settings => More networks => Mobile networks => Mobile data => Enable data access

when you want to send picture messages.

Stick with the standard APN on the Koodo site.

Can someone from Koodo please verify?

_______________
If you see a reply or comment you like, please give it a star
Photo of Jay

Jay

  • 152 Points 100 badge 2x thumb
Hey I am the person who made the post!

when i change the APNs to the koodo no data, and koodo mms allow, i turn on my data, and it automatically goes right back to the regular koodo APNs, which turns on my data that i get charged for! If i click the koodo no data APN again, and send a photo, it will go right back to the default koodo APN again!
Also, I understand that you need data for sending pictures, but when you change the APN to the Koodo (no data), and Koodo mms allow, it will block my phone from going onto the internet, or anything so my phone will only use the data for sending the photo, and therefore i wont get charged for my data usage. However, I cannot get this to work on my Nexus 5, as it always goes back to its default APNs!

Thank you very much for helping me out! I really appreciate it! :)
Photo of RudyW

RudyW

  • 21,890 Points 20k badge 2x thumb
And you say you were able to do that on another phone with koodo? In didn't think that was possible on all phones. It would make some people's life easier though.
Photo of Jay

Jay

  • 152 Points 100 badge 2x thumb
Yea! On my Samsung S2! It made my life a lot easier! There is no reason why you should have to pay for the data that your phone is using in the background while you are sending the photo! I was hoping I could figure out a way to do the same for my Nexus, but for the phones it does work on, good for them!
Photo of BobTheElectrician

BobTheElectrician

  • 67,204 Points 50k badge 2x thumb
Quick search of "picture message data" in the box at the top right of the page revealed not-too-good news.

As I suspected, mobile data has to be ON. MMS does not work over wifi. You will apparently not be charged for data use doing your picture messaging, but just hope that other apps are not pushing a big upload in your direction at the same time.

http://community.koodomobile.com/kood...
Photo of Jay

Jay

  • 152 Points 100 badge 2x thumb
It just sucks because my phone always did something in the background while I sent or opened a picture, and once you use data its an automatic 5 dollars extra for that little bit used! I know its not a lot but it can add up! When I changed the APNs on my Samsung, it allowed my phone to turn on its Data, but stopped my phone from going on the internet or anything else! So I never got charged! I was hoping someone knew a way to do the same type of thing on a Nexus
Photo of BobTheElectrician

BobTheElectrician

  • 67,204 Points 50k badge 2x thumb
It may well be that your previous phone allowed toggling the APN values during messaging, but that the Nexus may not support that feature.

For whatever reason, my Note II can't turn off data roaming independently (menu item is greyed out) so I have to globally choose data or no data when I'm in an "iffy" zone like near the US border .
Photo of Jay

Jay

  • 152 Points 100 badge 2x thumb
Ohhh so maybe the older phones had that ability? And the newer phones are more limited of that sort of thing?
Photo of Sandra Martin

Sandra Martin

  • 60 Points
I have a plan it not working
Photo of Mayumi

Mayumi, Mobile Master

  • 115,056 Points 100k badge 2x thumb
Hi Sandra
Is your data enable? What phone/plan do you have? What's exactry not working?
You should create your own question includes those info,then you have more chance to get  answers/helps
(Edited)
Photo of BobTheElectrician

BobTheElectrician

  • 67,204 Points 50k badge 2x thumb
Just for giggles, change the APN type value to

mms

(typed lower case).

The Koodo default is blank, which I assumes means "carte blanche" to everything.

AT&T lists

default,mms,supl

as required values.
Photo of Jay

Jay

  • 152 Points 100 badge 2x thumb
so get rid of all the values in koodo default? and keep the Koodo (no Data), and Koodo mms allow? and change their APN types to mms? or make a whole new one?!
Photo of Mayumi

Mayumi, Mobile Master

  • 115,056 Points 100k badge 2x thumb
Photo of BobTheElectrician

BobTheElectrician

  • 67,204 Points 50k badge 2x thumb
Make a new one called MMS test.

use these as basic values (Koodo default):

http://aide.koodomobile.com/Portals/0...



Just change the last line value where the APN type is supposed to be blank. I am just hoping that now you will connect to the internet only while MMS is active.
Photo of BobTheElectrician

BobTheElectrician

  • 67,204 Points 50k badge 2x thumb
Check out Mayumi's link in the Comment above. My hunch may be right, but it seems it's not so simple.

But I suspect that's where your original comments about mms allow, etc. came from.

Let us know how you make out. I'm not on the Koodo network currently so can't help you out by testing settings.
Photo of Jay

Jay

  • 152 Points 100 badge 2x thumb
The link you sent me is what I did for my S2 and worked, but does not work on my Nexus as it just automatically goes back to the default! And I just tried what you sent me in the second post! If I did what I think you are suggesting I don't think it worked!

I made another APN, with what you posted above, and I changed that APN to mms! I can still use the internet on it! Thank you very much though! I really do appreciate it!
Photo of BobTheElectrician

BobTheElectrician

  • 67,204 Points 50k badge 2x thumb
If your read between the lines after doing a search, it seems this really is a Koodo problem.

Important: did you power down the phone after the changes? Android is like stoopid Windoze... some values require reboot to be read!

This whole MMS thing has me laughing/crying. With the next generations of phones probably hitting 50+K megapixels on the camera side, nobody will be able to do anything to offload or share their pix unless data rates really drop.

Good luck !
Photo of rikkster

rikkster, Mobile Master

  • 68,302 Points 50k badge 2x thumb
Not necessarily as pictures are automatically converted to a more manageable size before they are sent, as they are today.
Photo of BobTheElectrician

BobTheElectrician

  • 67,204 Points 50k badge 2x thumb
My point precisely... why bother with mega mega pixels to begin with, other than a marketing gimmick.
Photo of rikkster

rikkster, Mobile Master

  • 68,302 Points 50k badge 2x thumb
I wouldn't call it a marketing gimmick and more of one's personal preference. We can offload pics to cloud storage or onto social media sites or send pics via email. Picture messaging provides a snippet of what you're phones' camera is capable of, no one is expecting to receive a 50 megapixel image in all its glory on their smartphone, usually a close enough facsimile will do.
Photo of Jay

Jay

  • 152 Points 100 badge 2x thumb
I did not but I just tried and it still did not work! It still goes back to default! What would happen if i deleted the default?! could that work? or could the fact that I have multiple APNs made right now affect what we are trying to do in any way?

and that is so true! And if the older phones could do it, why did they have to change the phones to stop allowing it!

Thank you very much for all of your help! I really do appreciate it! Take care :)
Photo of BobTheElectrician

BobTheElectrician

  • 67,204 Points 50k badge 2x thumb
Maybe we should start with a clean slate. Delete all the ?? APN's ?? you have kicking around. The Koodo defaults are posted on the wall above if nothing works. Go back to square 1 with Mayumi's post.

http://community.koodomobile.com/kood...

It's entirely possible that the first APN in the list becomes the default so I would clean house and set up the no data version as the first apn and name it Koodo. It is also possible that the default is coded into the SIM, so we may be out of luck trying to delete it.

The next one would be the MMS allow.

Be sure to follow power down/reboot. I would even pull the battery and SIM for a minute or so just to be sure.
Photo of rikkster

rikkster, Mobile Master

  • 68,302 Points 50k badge 2x thumb
Data used for picture messaging is not chargeable. If memory serves me correctly, this workaround will only work for older Samsung devices like the Galaxy Ace and Galaxy S2x. Reading further into the article below, LG devices will revert back to the default APN everytime, whereas Samsung devices do not. The topic below is a year old and it appears little has changed for LG in the APN department.

http://community.koodomobile.com/kood...

If you read the beginning of Chad's APN workaround example, it mentions that a data block has been removed (meaning that the OP now has data) and that the workaround prevents any 'additional data usage' (e.g., app updates, etc.). In other words, without data, you're just spinning your wheels. Even if you do get a data plan, there's no guarantee that this workaround will work on an LG device.
Photo of Mayumi

Mayumi, Mobile Master

  • 115,056 Points 100k badge 2x thumb
Thank you rikkster. I couldn't find the link you provided.
The link I found was mentioned nexus 5, so I thought it might help Jay.

It's too bad those method only work for older Samsung phones :/
It is nice workaround to have ( I think) :)
Photo of Jay

Jay

  • 152 Points 100 badge 2x thumb
Thank you very much for trying to help me! I appreciate it! It sucks that it only works for older Samsung phones for sure! :( Take care you guys!
Photo of BobTheElectrician

BobTheElectrician

  • 67,204 Points 50k badge 2x thumb
Try rikkster's latest post in the other thread:

http://community.koodomobile.com/kood...

You will have to enable data, but it should ONLY be non-chargeable pictures.

This conversation is no longer open for comments or replies.