Call Display is included in my plan but it never works

  • 1
  • Question
  • Updated 4 years ago
  • Answered
  • (Edited)
Archived and Closed

This conversation is no longer open for comments or replies and is no longer visible to community members. The community moderator provided the following reason for archiving: 1-866-995-6636

My plan states that Outbound Call Display is included but I've never had that actually happen when I call from my phone. It always states the caller as 'Unknown' when i'm making or receiving calls.

How can I enable call display?
Photo of Mat Nightingale

Mat Nightingale

  • 190 Points 100 badge 2x thumb

Posted 4 years ago

  • 1
Photo of Dennis

Dennis, Mobile Master

  • 187,022 Points 100k badge 2x thumb
Depending on your phone, go to your settings for your phone app and make sure Show My Caller ID is on
Photo of Mat Nightingale

Mat Nightingale

  • 190 Points 100 badge 2x thumb
Thanks for the reply, I'm using an iPhone 4S, it used to have caller display when I first got the koodo plan a few years ago but after a while I decided I didn't need it (it was a paid service at the time) so I removed it.

Now I want it back on, I login to my plan details on koodo and it states that it's included in my plan.

I don't see any software settings in the iPhone to turn it on.
Photo of Mat Nightingale

Mat Nightingale

  • 190 Points 100 badge 2x thumb
This is a joke. I suppose I'd better start looking at alternative providers.
Photo of Zaphod Beeblebrox

Zaphod Beeblebrox

  • 50,798 Points 50k badge 2x thumb
Over call display? Really? Take a look at your plan and the ones that are currently available. Chances are, it may end up being a better option to just change the plan.
Photo of Mayumi

Mayumi, Mobile Master

  • 112,530 Points 100k badge 2x thumb
What plan do you have? I used to had a $15 plan with no call display, no voice mail, no call waiting. I had 50 minutes airtime- no free evening, no free week end included. You might pay extra but you will get a lot more specially Koodo offers promo plan now.
Photo of Humberto Giambrone

Humberto Giambrone

  • 4,900 Points 4k badge 2x thumb
Tough to find any deals better than Koodo. Their competition all price match with one another and their parent companies are far worse. Depending on how you use your phone, and how often you use it, there may be some other things you can do.

If you only use your phone for local or provincial calls, Chatr would be a good alternative for unlimited calling from $20/month and $25/month, respectively (50 outgoing texts per month on both). They have a Canada-wide $35/month that includes unlimited text. It's on the Rogers network so coverage is solid. They include call display (but voicemail has a 25 cent per minute retrieval charge, except on the $35 plan, in which it is included). Note, to make the calls, you have to be in a Chatr zone, but their zones are pretty large in main centre's like Toronto, Montreal etc (I don't know where you are).

There are also the new entrants (of which I would recommend Wind over Mobilicity and Public Mobile), good prices but receptions in some areas might be an issue.
Photo of Sophia

Sophia, Mobile Master

  • 141,528 Points 100k badge 2x thumb
Depending on how much you use your phone and what features you need, prepaid might even be an option. I find the old $15/$20 plans and prepaid are very similar, in fact prepaid offers more than the $15 monthly plan. You would lose however your unlimited calling between family members on the same account... but it is an option to consider if you are a light user.
You could certainly shop around for other providers, but as others said already you might be hard pressed to find a better deal than Koodo :)
Photo of Timo Tuokkola

Timo Tuokkola, Mobile Master

  • 139,982 Points 100k badge 2x thumb
Outbound call is only to show your number on outbound calls. The setting to enable and disable this on an iphone is under settings->(phone/call)
Photo of quasarito

quasarito

  • 9,738 Points 5k badge 2x thumb
Does the person you are calling have caller id on their plan? Does your telephone number appear on their phone?
Photo of Mat Nightingale

Mat Nightingale

  • 190 Points 100 badge 2x thumb
Yes, it's my wife she. We're both on the same plan (same account even) with same phones. The receiving phone just says 'Unknown' when I call.
Photo of quasarito

quasarito

  • 9,738 Points 5k badge 2x thumb
Hmmm. We need to find out on whose side the problem is occurring: yours or your wife.

Can you call someone else who has caller id and check that your telephone number displays on their phone? If it does, then it would indicate that it is something with your wife's plan/phone.

Does your wife's phone properly display other incoming callers telephone number? If so, this could indicate that the problem is on your side.
Photo of Mat Nightingale

Mat Nightingale

  • 190 Points 100 badge 2x thumb
I just called a friend (with caller ID) who has removed me from their contacts and my phone comes up as Unknown. Whether my friend is in my contacts or not it lists the incoming call as Unknown.

Neither phone displays callerID from anyone.
Photo of Dennis

Dennis, Mobile Master

  • 187,022 Points 100k badge 2x thumb
Mat, others should be receiving your number when you call them (if they have call display).

At this point we know it should work, but it seems like it doesnt.
My recommendation would be to call Tech Support at Koodo to see what's going on 1-866-995-6636
Photo of quasarito

quasarito

  • 9,738 Points 5k badge 2x thumb
You may have your caller id blocked by Koodo. Log in to Self Serve and verify that it is disabled.

In Self-Serve, under Plans and Add-ons > Add-ons, scroll down to Change Optional Add-ons and verify that Call Display Restrict is unchecked.

Photo of Mat Nightingale

Mat Nightingale

  • 190 Points 100 badge 2x thumb
I've checked my account and that box is unchecked.

This conversation is no longer open for comments or replies.