Bug on Self Serve Website - Page Not Found

  • 1
  • Question
  • Updated 1 week ago
  • (Edited)
  1. login into koodomobile.com
  2. Select View My Bill
  3. Beside "Pre-authorized debit payments"  click on Manage.
  4. You get Page Not found
I found a way around it (I think).
  1. Click on Self Serve/Billing
  2. Then Click on Edit beside Bill Notifications.
  3. That gets you into a different looking web page (blue header).
  4. From there you can click on preauthorized payment and set it up (I assume).
Should I apply for a job at this company? I'm a software developer and bugs like this don't get past me!
Photo of Jerrrrrrr

Jerrrrrrr

  • 482 Points 250 badge 2x thumb

Posted 2 weeks ago

  • 1
Photo of Bernard

Bernard, Official Rep

  • 81,138 Points 50k badge 2x thumb
Hmmmm...followed the exact steps and didn't have the issue with Page Not Found;


 

Not sure why. Could have been a temporary glitch? 
Photo of Jerrrrrrr

Jerrrrrrr

  • 482 Points 250 badge 2x thumb
It's been that way for 3 days (since I signed up for koodo). I tried 2 browsers (IE and Firefox).
What browser/device did you use?
Photo of Jerrrrrrr

Jerrrrrrr

  • 482 Points 250 badge 2x thumb
Photo of Bernard

Bernard, Official Rep

  • 80,692 Points 50k badge 2x thumb
Chrome. Will check on Firefox tonight.
(Edited)
Photo of Jerrrrrrr

Jerrrrrrr

  • 482 Points 250 badge 2x thumb
Tried with my iPhone, same thing. Maybe it's because my region is Alberta?
Photo of Jerrrrrrr

Jerrrrrrr

  • 482 Points 250 badge 2x thumb
In the bottom left of the image, you can see the mouse hover over the "Manage" link of "Pre - authorized debit payments".
Photo of Bernard

Bernard, Official Rep

  • 81,048 Points 50k badge 2x thumb
Now things get even odder....you should see what I see. 



I'm not convinced it has to do with you being new. Otherwise we would get this issue daily from tons of customer. I'm leaning towards something with your account, but can't state it for sure without seeing. If it is indeed what you are saying, I will make it worthwhile for you. :-) Yes, there will be a reward. :-) 
Photo of Jerrrrrrr

Jerrrrrrr

  • 482 Points 250 badge 2x thumb
I guess we'll see what happens when the bill is generated. I think that's pretty soon. I'll let you know what happens. I was semi serious about job openings actually. But we can talk offline.
Photo of Jerrrrrrr

Jerrrrrrr

  • 482 Points 250 badge 2x thumb
I see there are quite a number of jobs at Telus. I'll have to investigate.
Photo of Dinh

Dinh, Mobile Master

  • 42,136 Points 20k badge 2x thumb
I don't see a correlation between an opening at Telus and this issue. Did they tell that they needed someone to fix the prepaid web in the posting?. Telus is the parent company of Koodo but they have separate management though. You might end up in Telus prepaid if you apply and succeed.
(Edited)
Photo of Jerrrrrrr

Jerrrrrrr

  • 482 Points 250 badge 2x thumb
Anyway. Clearly it's pooched. I'll leave it with you.
Photo of Jerrrrrrr

Jerrrrrrr

  • 482 Points 250 badge 2x thumb
Just thought of something. Maybe it's because I'm a NEW customer and there's NO BILL yet. Perhaps the web page just before the pre-auth page normally sends a token based on a bill or something. Anyhow. That's the way it is and the way it's working for me. Not my issue. Not my browser. Not my OS. Not my network.
Photo of Jerrrrrrr

Jerrrrrrr

  • 482 Points 250 badge 2x thumb
So far I've tried the latest FF on Windows 7 and safari on my iPhone with the same results.
Photo of Robert

Robert, Mobile Master

  • 106,744 Points 100k badge 2x thumb
It would be interesting to know if that's the issue.
Photo of Jerrrrrrr

Jerrrrrrr

  • 482 Points 250 badge 2x thumb
Do any of you work at Koodo? If so, pass it to your web guys. Thanks
Photo of Allan

Allan, Mobile Master

  • 61,880 Points 50k badge 2x thumb
Bernard above does. The thing is they need to be able to re create the issue in order to solve it.
Photo of Jerrrrrrr

Jerrrrrrr

  • 482 Points 250 badge 2x thumb
Turns out that it was because there was NO BILL yet. Now that I have a Bill available, the link is working. So from Step 3 I am now getting the "Select Your Payment Method" page.
So it's exactly what I thought. No bill, no token...no page....Should be an easy fix for your developers. I'll take a cash reward :)