bad sim card

  • 1
  • Question
  • Updated 5 years ago
  • Answered
Archived and Closed

This conversation is no longer open for comments or replies and is no longer visible to community members. The community moderator provided the following reason for archiving: *611 or 1-866-995-6636 mentions

my phone keeps restarting after getting no signal. i suspect it to be a sim card issue since this doesn't happen in airplane mode.

will i be charged a fee for replacing the sim card? and can this be done at any bestbuy locations? or do i have to visit a koodo store?
Photo of MVC

MVC

  • 396 Points 250 badge 2x thumb

Posted 5 years ago

  • 1
Photo of John Burke

John Burke, Mobile Master

  • 71,346 Points 50k badge 2x thumb
How long have you had that particular SIM?
Have you tried another SIM in your phone?
Have you tried yours in another phone?
What's your phone?
Photo of Paul Deschamps

Paul Deschamps, Mobile Master

  • 203,838 Points 100k badge 2x thumb
I take it the phone is unlocked to work on other providers than the one it was sold from? What carrier is it from and did the phone work on the other carrier?
Photo of MVC

MVC

  • 396 Points 250 badge 2x thumb
the phone was from bell, but it works on big4 and mobilicity. have been working on koodo for a few months
Photo of Myke

Myke

  • 45,090 Points 20k badge 2x thumb
Before replacing the sim, get a network ticket logged so it can be investigated.
Photo of MVC

MVC

  • 396 Points 250 badge 2x thumb
how can this be done?
Photo of Myke

Myke

  • 45,090 Points 20k badge 2x thumb
Call Koodo Tech. *611 Option 6..
Photo of MVC

MVC

  • 396 Points 250 badge 2x thumb
So i think i found a fix. not sure yet., i've got the i717M (note 1 bell)

this i've tried and didn't work:
flashing stock rom with odin
flashing different modem
replacing/ejecting sd card
replacing simcard
turning off data

what i did to get it working:
flashing stock telus JB rom
flashing telus modem

perhaps i am the only one, but i think telus network disconnects you if you're not using their phones/modem

hope my fix helped others with the same problem

This conversation is no longer open for comments or replies.