Bad reception?

  • 1
  • Question
  • Updated 2 years ago
  • Answered
I just got the Nexus 5 with koodo switched from Rogers and it has no reception at all in maple ridge. I never had a problem with Rogers.
Photo of stephanie f

stephanie f

  • 150 Points 100 badge 2x thumb
  • angry

Posted 2 years ago

  • 1
Photo of Chad Burr

Chad Burr, Mobile Master

  • 203,988 Points 100k badge 2x thumb
I'm assuming Maple Ridge ontario which has great coverage so it's likely a phone setting

Goto

Settings...wireless and networks...more...mobile networks...

Network selection should be set to auto
Photo of Chad Burr

Chad Burr, Mobile Master

  • 203,988 Points 100k badge 2x thumb
Just some basic stuff I want to ask

It's a koodo Sim you have right?

Where did you get your phone?
Photo of stephanie f

stephanie f

  • 150 Points 100 badge 2x thumb
Koodo sim. I ordered my phone from koodo and received it in the mail yesterday
Photo of Chad Burr

Chad Burr, Mobile Master

  • 203,988 Points 100k badge 2x thumb
Did you call in and activate your Sim card?
Photo of stephanie f

stephanie f

  • 150 Points 100 badge 2x thumb
Activated online
Photo of Navdeep Singh

Navdeep Singh

  • 470 Points 250 badge 2x thumb
Just call on the customer service from any other phone and you should be fine
Photo of stephanie f

stephanie f

  • 150 Points 100 badge 2x thumb
Maple ridge British Columbia
Photo of stephanie f

stephanie f

  • 150 Points 100 badge 2x thumb
Does koodo allow returns and cancellations cause I will definitely go back to Rogers if there's no fix lol
Photo of Chad Burr

Chad Burr, Mobile Master

  • 203,988 Points 100k badge 2x thumb
Go back to the settings above and switch network selection to manual. The phone will scan and give you a list of available networks. Is koodo or telus one of them? Choose either

Do you have reception at all anywhere else?

Make sure 'use GSM only" or "use 2g only" isn't selected

Make sure network type is set to wcdma/gsm auto or something similar...
Photo of Chad Burr

Chad Burr, Mobile Master

  • 203,988 Points 100k badge 2x thumb
Also can you answer this question after you tell me about activation?
Photo of stephanie f

stephanie f

  • 150 Points 100 badge 2x thumb
Phone was activated yesterday. It's on 4g LTE mode so it shouldn't have a problem
Photo of Chad Burr

Chad Burr, Mobile Master

  • 203,988 Points 100k badge 2x thumb
Do you have reception at all anywhere else?

This conversation is no longer open for comments or replies.