Authentication error occured when trying to connect to wifi!!!

  • 6
  • Question
  • Updated 5 months ago
  • Answered
Archived and Closed

This conversation is no longer open for comments or replies and is no longer visible to community members.

How can i fix my wifi problem on my SAmsung Galaxy Ace IIx. My wifi was working fine until 2 days ago when my phone got disconnected randomly. I tried to reconnect but my phone says authentication error occured. I am entering the password right for sure and i even tried restoring the phone to factory settings but no help. What do i do? Thank you.
Photo of Sahit Gutta

Sahit Gutta

  • 418 Points 250 badge 2x thumb

Posted 5 years ago

  • 6
Photo of rikkster

rikkster, Mobile Master

  • 67,080 Points 50k badge 2x thumb
If it's your own wireless network you're having difficulty with, unplug your wireless router until all the indicator lights go out, then plug the wireless router back in. Make sure all the lights come back on and ensure that your router is visible from your Ace 2x by performing a Wi-Fi scan. If the Ace 2x "sees" and connects to your Wi-Fi network, disregard the next step. If not, on your Ace 2x, "forget" the network you are trying to access, re-enter the necessary credentials and try connecting to your wireless router. Let us know if that corrects the problem.
Photo of Renee Noel

Renee Noel

  • 60 Points
there is not problem with my labtop and my wireless network
Photo of Dylan Skypiercer

Dylan Skypiercer

  • 60 Points
hey guys just thought I'd add this but, I was with virgin mobile for a while, and my service was cut off recently. And while I was trying out all these "fixes" I came across the idea of taking out my sim card and keeping the cover off while I connected I booted up my phone. and surprisingly it automatically connected to my wifi again. It hasn't connected in months. So....the question is.....maybe your provider doesn't want you on wifi. TRY IT YOURSELF IF IT DOESNT WORK WHATEVER IM JUST PUTTING WHAT WORKED FOR ME
Photo of Timo Tuokkola

Timo Tuokkola, Mobile Master

  • 139,982 Points 100k badge 2x thumb
Correlation does not equal causation.
Photo of Gabriela

Gabriela

  • 62 Points
3890pts
Photo of Ivan

Ivan, Mobile Master

  • 96,382 Points 50k badge 2x thumb
Congratulations!
Photo of Sahit Gutta

Sahit Gutta

  • 418 Points 250 badge 2x thumb
I tried all of that and i even did it many times but no luck. The phone says authentication error again. Also the phone is not connecting to any wifi network, it is having the same problem with every wifi i try to connect to.Also, will koodo replace my phone? I got this phone on Boxing Day of 2012.
Photo of Timo Tuokkola

Timo Tuokkola, Mobile Master

  • 139,982 Points 100k badge 2x thumb
The warranty lasts for 1 year from the date of purchase and would cover this issue, as long as there is no physical or liquid damage to the phone. Systems are down for maintenance until at least 3 pm ET today though, so customer suport won't be much help until they're back up.
Photo of MatB

MatB

  • 32,458 Points 20k badge 2x thumb
Reseting wi-fi connection by dialing this number *#*#526#*#* will help, else use 3G Data and download Wi Fi Fix apps from Google Play
https://play.google.com/store/apps/de...
This apps is intended to fix any issue with Android phones Wi-Fi issues
Photo of Sahit Gutta

Sahit Gutta

  • 418 Points 250 badge 2x thumb
When i type the code, the phone just stays in the dialer app with the code typed. There is no reaction. I will try the app though.
Photo of Sahit Gutta

Sahit Gutta

  • 418 Points 250 badge 2x thumb
I tried that app and many other apps but they have seemed to make no difference.
Photo of Rocky Balboa

Rocky Balboa

  • 20,414 Points 20k badge 2x thumb
Try switching out the sim cards and unplugging the battery and sim! It would isolate the issue with the sim or phone
Photo of rikkster

rikkster, Mobile Master

  • 67,040 Points 50k badge 2x thumb
The SIM card has nothing to do with Wi-Fi. I'm running an Ace 2x in Airplane mode and another with the SIM card completely removed from the device. Both are receiving Wi-Fi without issue.
Photo of rikkster

rikkster, Mobile Master

  • 67,040 Points 50k badge 2x thumb
@Sahit. *#9090# will invoke the diagnostic configuration window. Press the menu softkey to the left of the home button and a menu will appear. Select Wi-Fi, to confirm connection status and both your devices' and the wireless router's MAC address. You can also ping your wireless router's IP address to confirm your Ace 2x is communicating correctly with your router.
Photo of MatB

MatB

  • 32,458 Points 20k badge 2x thumb
SIM card does not have an impact on Wi-Fi for, it's just to let her try different handset to find out if it's phone or router problem, she can also use these two workarounds
Try this Wi-Fi Connectivity Workaround suggested on this same community

First workaround
This method resets/reloads the WLAN or Wi-Fi driver in your Ace.
From your dial-pad enter: *#*#526#*#* wait for the following status message to appear.
WLANTest Engineering Mode
Status...
Driver loading successful
To exit, tap the Back button.

First workaround
First, go to Settings > Wireless and networks > Wi-Fi settings
Tap on Wi-Fi settings and enable Wi-Fi and Network notification.
Next, click on the Menu button and choose Advanced.
In Advanced mode, scroll down to IP settings and input the following:
(Be sure to checkmark the "Use static IP" box before continuing with this procedure).
IP address > 192.168.2.130
Gateway > 192.168.1.1
Netmask > 255.255.255.0
DNS 1 > 8.8.4.4
DNS 2 > 4.4.4.4
Tap on the Menu button and choose Save.
Remember to disable the "Use static IP" option. For example, if you are only experiencing Wi-Fi connectivity problems with your home wireless router, yet you are able to access Wi-Fi through a wireless router at work - disable the option prior to using the work router.
One last method to resolve a connectivity issue with your wireless router is to simply unplug the router until all of the status lights have turned off (approximately thirty seconds or so) then plug it back in. On most wireless routers there are options to specifically assign your device to the wireless router.
Photo of Timo Tuokkola

Timo Tuokkola, Mobile Master

  • 139,982 Points 100k badge 2x thumb
I don't think your static solution will work as you've posted it. You have the ip and the gateway on different subnets with a class C subnet mask. They aren't going to see each other.
Photo of Sahit Gutta

Sahit Gutta

  • 418 Points 250 badge 2x thumb
I tried all of the above guys but none of them seemed to work.
i also have the same problem :(((
Photo of Daniel Sakchekapo

Daniel Sakchekapo

  • 60 Points
so, what do we do? because i am trying everything as well and i have no idea on how to get this better
Photo of Mayumi

Mayumi, Mobile Master

  • 112,704 Points 100k badge 2x thumb
When did you get your phone? Was it working before?
Photo of Sahit Gutta

Sahit Gutta

  • 418 Points 250 badge 2x thumb
I just traded it in for a nexus four. Since Samsung also refused to fix it under warranty!!
Photo of Evelyn Cortez

Evelyn Cortez

  • 60 Points
I'm having the same problem and i just recently bought my phone so this is really frustrating.
Photo of Pradyum Gupta

Pradyum Gupta

  • 60 Points
hey man i am also facing that same stupid problem ..and the worst part is now my phone warranty is also over..pls let me know i u gys find out a solution
btw i checked it on net after hours of surfing it says that there is Firm ware problem..
Photo of Brad Pitt

Brad Pitt

  • 70 Points
I had the same issue on my Galaxy S8. It will connect for a minute and then it was disconnected automatically and display a message "Unable to connect" but the WiFi is working on all other devices. I tried this wifi authentication solution but not work for me, It works well for my friend.

This conversation is no longer open for comments or replies.