Android Maxwest Astro 4.5 - Can't send MMS

  • 1
  • Question
  • Updated 1 year ago
Data is on and works fine for internet and maps. Connected to Koodo network with full bars, and it says "4G." I turned wifi off just in case. Tried restarting my phone. Using the native messaging app, and while regular SMS works fine, I can't send an MMS. The settings say MMS is an option, and my picture is almost half of the image size limit in settings. 

I have checked and double checked the Koodo APN settings for Android, and they are all set up properly.

Help!
Photo of Sara Marie

Sara Marie

  • 214 Points 100 badge 2x thumb
  • frustrated

Posted 1 year ago

  • 1
Photo of Chad Burr

Chad Burr, Mobile Master

  • 203,988 Points 100k badge 2x thumb
I know you said you checked the APN settings but can you post a screenshot of what you have there. Thanks.


Also try clearing the cache and data from the messaging app,.


You can also try downloading a third-party messenger app. I love chompSMS for this over the built in messaging platform.
(Edited)
Photo of Dennis

Dennis, Mobile Master

  • 196,866 Points 100k badge 2x thumb
Ive recently switched from ChompSMS to Textra.  They are made by the same company
Photo of Sara Marie

Sara Marie

  • 214 Points 100 badge 2x thumb
Photo of Sara Marie

Sara Marie

  • 214 Points 100 badge 2x thumb
Photo of Sara Marie

Sara Marie

  • 214 Points 100 badge 2x thumb
Photo of Sara Marie

Sara Marie

  • 214 Points 100 badge 2x thumb
Ok I dowloaded Texto, and this is now the second 3rd party messaging app I've tried. It just cycles through these green "loading" dots and won't send.
Photo of Sara Marie

Sara Marie

  • 214 Points 100 badge 2x thumb
About 10 min later, it finally says it failed to send.
Photo of Chad Burr

Chad Burr, Mobile Master

  • 203,988 Points 100k badge 2x thumb
Edit your APN and add "MMS"under APN Type.

APN Type: default,mms
Photo of Sara Marie

Sara Marie

  • 214 Points 100 badge 2x thumb
OMG this was it. I spent an hour on the phone today with Koodo customer service. I read all my APN settings out to him, reset the phone to factory default, and re-entered all the APN details all with him on the phone. Arg!

Thank-you, kind sir!
Photo of Chad Burr

Chad Burr, Mobile Master

  • 203,988 Points 100k badge 2x thumb
Awesome! Glad it worked out for you! Happy messaging!
Photo of Sara Marie

Sara Marie

  • 214 Points 100 badge 2x thumb
I've also noticed that even though the date & time settings are set to automatically update from the carrier, it's 2 hours off.
Photo of Allan

Allan, Mobile Master

  • 62,876 Points 50k badge 2x thumb
Do you have both "Auto-date & time" and "Auto-time zone" turned on? If so just turn them off and on again and it should reset it and fix itself.
(Edited)
Photo of Sara Marie

Sara Marie

  • 214 Points 100 badge 2x thumb
Hmmm i've tried this a few times. It's only right if I manually select the time zone.
Photo of Chad Burr

Chad Burr, Mobile Master

  • 203,988 Points 100k badge 2x thumb
Unless you travel frequently, you can just leave it on the manually selected time zone. It won't have a negative impact on anything.