All40 still no service

  • 1
  • Question
  • Updated 1 year ago
  • Answered
Archived and Closed

This conversation is no longer open for comments or replies and is no longer visible to community members. The community moderator provided the following reason for archiving: no longer relevant

Hello, I just added the ALL40 add-on through Koodo app and have done a soft reset on my iPhone 6 but I still get 'No Service'. How do I fix this?
Photo of KA AL

KA AL

  • 70 Points

Posted 1 year ago

  • 1
Photo of Mayumi

Mayumi, Mobile Master

  • 115,204 Points 100k badge 2x thumb
Did you add the "international roaming add-on($0/mo) from self serve too?
Then re start your phone.
Photo of Robert

Robert, Mobile Master

  • 107,634 Points 100k badge 2x thumb
Hello there,

While travelling, there are 2 reasons why you might not get service.

FIRST, since you are outside of Canada no Canadian carrier owns any networks. Koodo relies on the services of local providers. Depending on where you are coverage maybe better than other places. Having no coverage from the local provider may result in you having no service. If that's the case for the whole trip, then you might want to give Koodo a call when you come back to get your money back since you haven't used the service.

SECOND, Have you added the free international roaming package from self serve? Is data roaming enabled on your phone? If you are not in the USA, you require the free International voice add-on be active on your account to connect to other carriers. If you didn't add them prior to your departure, add them (click here to know how) and then turn airplane mode on for 30 seconds and off.

Wish you a wonderful vacation!

This conversation is no longer open for comments or replies.