ALL40 not working

  • 1
  • Question
  • Updated 9 months ago
  • Answered
Archived and Closed

This conversation is no longer open for comments or replies and is no longer visible to community members. The community moderator provided the following reason for archiving: No longer valid due to Easy Roam

I have activated my international data using ALL40 but I don't have internet connection. I'm currently in Lisbon and I need to use the data ASAP
Photo of Nada


  • 130 Points 100 badge 2x thumb

Posted 9 months ago

  • 1
Photo of Allan

Allan, Mobile Master

  • 50,828 Points 50k badge 2x thumb
Do you have the $0 International Data Roaming add-on added to your account? Do you have data roaming enabled on your phone?

Do you currently have any service? Have you tried restarting your phone?
Photo of Robert

Robert, Mobile Master

  • 101,484 Points 100k badge 2x thumb
Hello there,

While travelling outside the US, there are 2 reasons why you might not get service.

FIRST, since you are outside of Canada no Canadian carrier owns any networks. Koodo relies on the services of local providers. Depending on where you are coverage maybe better than other places. Having no coverage from the local provider may result in you having no service. If that's the case for the whole trip, then you might want to give Koodo a call when you come back to get your money back since you haven't used the service.

SECOND, Have you added the free international roaming package from self serve? Is data roaming enabled on your phone? If you are not in the USA, you require the free International voice add-on be active on your account to connect to other carriers. If you didn't add them prior to your departure, add them (click here to know how) and then turn airplane mode on for 30 seconds and off.

Wish you a wonderful vacation!

This conversation is no longer open for comments or replies.