ALL40 add-on in London; data won't work???

  • 1
  • Question
  • Updated 11 months ago
Archived and Closed

This conversation is no longer open for comments or replies and is no longer visible to community members. The community moderator provided the following reason for archiving: No longer valid due to Easy Roam

I added ALL40 in london (I am from Canada) and received confirmation that I was all set to go; however, I cannot connect to the internet using data. I turned Modlie Data ON in my settings. I have restarted the phone.  It is not on airplane mode.  Wifi works.  Any suggestions?
Photo of Rebecca Barnstaple

Rebecca Barnstaple

  • 100 Points 100 badge 2x thumb
  • Super bummed cuz data is why I added ALL40

Posted 11 months ago

  • 1
Photo of David

David, Mobile Master

  • 89,024 Points 50k badge 2x thumb
Here are the steps recommended the past:

Sign into the Koodo self serve website. Make sure to add the free “International Voice Roaming" and / or the free “International Data Roaming” add on. Also make sure Pay-per-use International Long Distance is active. Then turn airplane mode on and off. When your phone connects it should be working. Buying any of the Travel Add-ons on a postpaid plan only nets you a savings on your roaming fees, it does not change anything about the ability of the phone to roam. Without the Voice / Text / Data Add-on, you can still roam at pay-per-use prices. On a pre-paid plan, the US Roaming Boosters last until consumed. See this post for more details: https://community.koodomobile.com/koodo/topics/roaming-texting?topic-reply-list%5Bsettings%5D%5Bfilter_by%5D=all&topic-reply-list%5Bsettings%5D%5Breply_id%5D=18384349#reply_18384349
Photo of Dennis

Dennis, Mobile Master

  • 187,452 Points 100k badge 2x thumb
In settings under Mobile Networks make sure Data Roaming is enabled
Photo of Rebecca Barnstaple

Rebecca Barnstaple

  • 100 Points 100 badge 2x thumb
Yay that fixed it!  Thanks Dennis!

This conversation is no longer open for comments or replies.