Add-on data not working

  • 1
  • Question
  • Updated 4 weeks ago
A while ago I bought 500 Mo and even though I can still see on my account that it's there, I can't use it! I've tried going to the store so they could fix it but they told me that I need to call from my phone. So once I got home, I called and waited around 2 hours and still didn't get answered so I hung up. I've been on many websites and Q&As but whatever method I tried didn't work. When I try to use my data it says that I need to turn it on (even though it's on) or that I'm not subscribed to a cellular data service (even though its says that I still have my 500 Mo untouched on my account). I've been trying to fix this problem for a while now and it really frustrates me.
Photo of Sofia Ababii

Sofia Ababii

  • 70 Points
  • Frustrated

Posted 4 weeks ago

  • 1
Photo of David

David, Mobile Master

  • 93,430 Points 50k badge 2x thumb
You do have cellular data turned on on your phone? There is an option to turn it off.
(Edited)
Photo of Dennis

Dennis, Mobile Master

  • 196,006 Points 100k badge 2x thumb
Are you prepaid or post paid. What do you mean by data add-on?
Did you receive a shock free data warning?

Did data work previously?

Did you restart your phone?