"Unable to connect to this at this time." Why?

  • 1
  • Question
  • Updated 5 years ago
  • Doesn't Need an Answer
For some reason, since yesterday, my phone (HTC Hero) has been unable to connect to the Koodo network, no matter what I do. I know that it's not a problem of the antenna, because I am able to connect to wifi just fine. It's not obviously a problem of either the SIM card or the phone, because when I put the Koodo sim card in another phone, it works immediately; I immediately get a flood of texts. As for the phone, when I put a Fido SIM card from a friend's phone, it connected to the network immediately.

I have done a factory reset, cleared the cache and the Dalvik cache, tried blowing out any dust that might have gotten into the phone, and more. I've called HTC and they're stumped. I dunno what to do. My plan is to go to the Koodo store near me tomorrow morning and insist on getting a new SIM card, but let me know if there's anything I've failed to do?
Photo of Gavin

Gavin

  • 100 Points 100 badge 2x thumb
  • frustrated

Posted 5 years ago

  • 1
Photo of Myke

Myke

  • 45,090 Points 20k badge 2x thumb
What provider was the phone originally with? How long have you had the phone active on your Koodo account?
Photo of Gavin

Gavin

  • 100 Points 100 badge 2x thumb
It was originally with Telus. I have had it active with Koodo since April or May, I think April.
Photo of Dennis

Dennis, Mobile Master

  • 196,672 Points 100k badge 2x thumb
First thing. Is 3G on?

Did you complete an update to the OS?

And after that I would test another working Koodo sim and then a Telus Sim
Photo of Gavin

Gavin

  • 100 Points 100 badge 2x thumb
No, 3G is not on. It actually won't turn on.

I haven't done any updates for the OS in a long time, nor have I started one and cancelled it midway.
Photo of Dennis

Dennis, Mobile Master

  • 196,672 Points 100k badge 2x thumb
Ok to use Koodo's network you need to have 3G enabled.
Are you using a widget to turn on 3G or going through Menu > Settings
Photo of Gavin

Gavin

  • 100 Points 100 badge 2x thumb
Excuse me, I was incorrect. 3G is on, and it actually won't accept my choice if I tell it to "use only 2G networks". I was using Menu > Settings, not a widget.

This conversation is no longer open for comments or replies.