" My Phone Number" shows as "Unknown".

  • 2
  • Question
  • Updated 4 years ago
  • Answered
I have a samsung android phone. When my Rogers Sim is installed and I got to the settings / about phone the " My Phone Number" shows the Rogers phone number. When my Koodo Sim card is install the " My Phone Number" shows as "Unknown". Any ideas why?
Photo of Ross MacDonald

Ross MacDonald

  • 100 Points 100 badge 2x thumb

Posted 5 years ago

  • 2
Photo of Paul Deschamps

Paul Deschamps, Mobile Master

  • 199,438 Points 100k badge 2x thumb
Is the phone a Rogers bought phone? If so that could be the reason as its not a phone from Koodo, I know that my factory unlocked Galaxy Note 2 doesn't show my phone # under that area in the settings menu but using my Nexus 4, Galaxy S3, or Galaxy S4 bought from Koodo it does show my # in that area. Either way it doesn't affect the phone in any way so it's nothing to worry about.
If you like having your # on your phone to remember it you can do what I do and just make an entry into your contacts as "ME" & input your phone # & other info there. Then if you need any of your own contact info Luke phone #, email addresses, ect it's all there in your contacts as ME
Photo of Robert

Robert, Mobile Master

  • 103,464 Points 100k badge 2x thumb
I have exactly the same thing! But, when I go into my contacts there's an already made category on top which is called me and it has my phone number there.
Photo of Paul Deschamps

Paul Deschamps, Mobile Master

  • 199,438 Points 100k badge 2x thumb
Ya the newer Android phones I think those running Android 4.1and newer have a place in the contacts already set that says Me and there's a click able option to "set your profile". They stole my idea lol ;-)
Photo of Ross MacDonald

Ross MacDonald

  • 100 Points 100 badge 2x thumb
I see the ME and have set it up. My original phone - which I still have is a Samsung Galaxy Nexus which was a Google phone that only came unlocked. My original service provider at that time was Telus and the My Phone Number showed the correct number. I then moved to Roger's and the My Phone Number worked. I got Koodo as a second account due to travel areas and better coverage but the Koodo in the Nexus never showed in My Phone Number. Needless to say switching SIM is a pain so I have just purchase a Samsung Galaxy Grand Duos (GT-I9082) - which is a dual sim unlocked phone. The Rogers SIM phone numbers display correctly and immediately but again the Koodo phone number still shows as Unknown.
Photo of Ross MacDonald

Ross MacDonald

  • 100 Points 100 badge 2x thumb
And thanks for your assistance and comment none the less guys. It's appreciated.
Photo of MykeC

MykeC

  • 20,174 Points 20k badge 2x thumb
Hey Ross, this number will be updated on it's own by the system. It may take time before it changes. This isn't anything to worry about though.

________________________

If you see a good answer, give it a star.

Photo of Kate Bernhardt

Kate Bernhardt

  • 60 Points
I have the ME field in Contacts in my new Galaxy S4 Active, sync'd to my Google Contacts. The ME entry is currently empty - and it doesn't allow me to add any phone number fields! What's up with that?
Photo of Chad Burr

Chad Burr, Mobile Master

  • 203,968 Points 100k badge 2x thumb
Try editing it through http://contacts.google.com

This conversation is no longer open for comments or replies.