"Mobile network not available" for a week?

  • 1
  • Question
  • Updated 5 years ago
  • Answered
Archived and Closed

This conversation is no longer open for comments or replies and is no longer visible to community members. The community moderator provided the following reason for archiving: 1-866

"Mobile network not available". It's been like this for a week. 4 bars. I live in Canada and the phone started working when I went near the US border and I received a message that said I'd entered the states. When I left the area, it stopped working again. I've turned it on and off, taken out the battery and sim card, and turned flight mode on and off. its a samsung galaxy. What can I do?
Photo of Its Me

Its Me

  • 90 Points 75 badge 2x thumb

Posted 5 years ago

  • 1
Photo of Chad Burr

Chad Burr, Mobile Master

  • 203,988 Points 100k badge 2x thumb
Hey Its Me, It's me too

Cycle your Airplane mode on and off
Then Cycle your Wifi on and off

if that doesn't work
Goto

Settings - Wireless and Networks- Mobile Networks - Network Selection

If It's set to Automatic, Set it to manual and scan for Telus or Koodo. When they show up select either.

If it's set to Manual, Set it to automatic and let it scan.

I'll be waiting by my keyboard so you can tell if any of that worked for you
Photo of Its Me

Its Me

  • 90 Points 75 badge 2x thumb
none of that worked. it said i couldnt connect to koodo's network. its not set to 2g only either.
Photo of Timo Tuokkola

Timo Tuokkola, Mobile Master

  • 142,506 Points 100k badge 2x thumb
It actually sounds like the phone is set to 2g/gsm only. AT&T and T-Mobile both offer 2G service, koodo doesn't, which would explain why it works when roaming but not at home.
Check under settings->more settings->mobile networks->network mode. It should be set to auto.
Photo of Chad Burr

Chad Burr, Mobile Master

  • 203,988 Points 100k badge 2x thumb
UGH!!!! I didn't think of that!!! That would totally explain it! But the SGA usually says "unregistered sim" so thats what threw me off. Only time will tell. Hopefully we'll get an answer from the Original Poster (OP) soon!
Photo of Its Me

Its Me

  • 90 Points 75 badge 2x thumb
none of that worked. it said i couldnt connect to koodo's network. its not set to 2g only either.
Photo of Yannick

Yannick

  • 44,018 Points 20k badge 2x thumb
Hi there, at that point, I suggest that you contact our technical support directly over the phone. We can be reached at 1-866-995-6636 from a landline, #6. Thank you!

________________________
If you see a good answer, give it a star.

This conversation is no longer open for comments or replies.