1 800 numbers won't work (call quality)!

  • 1
  • Question
  • Updated 4 years ago
  • Answered
Archived and Closed

This conversation is no longer open for comments or replies and is no longer visible to community members. The community moderator provided the following reason for archiving: *611 or 1-866-995-6636 mentions

Every time I call 1-800 numbers or other 1-8** numbers on my koodo phone, the call quality is horrible. (persons voice cuts out, skips for seconds etc). It always works from my other friend's cell phones. The problem does not happen on non-1-8** numbers. It does not happen on specific 1-8** numbers but ALL of them.. and again this does not happen from any other phone I use. What's up with that? It's the only 1 problem I've had with koodo so far and nobody has helped me with it. By the way, my plan is just a regular month to month canada wide plan that I use normally for all other occasions without hassle. And im using a blackberry pearl from a couple years ago. Always had the issue. Koodo has "reset" some network setting from their side or offered basic hard reset option but it does not fix the issue.
Photo of Botchbud Botchbud

Botchbud Botchbud

  • 80 Points 75 badge 2x thumb

Posted 4 years ago

  • 1
Photo of Ivan

Ivan, Mobile Master

  • 95,532 Points 50k badge 2x thumb
Personally, I've found call quality to be subpar with toll-free numbers no matter what network or phone I may be using. Hopefully someone will be able to help you out here but I'd advise to call-in and speak to tech support. I can't think of a single thing that we'll be able to do for you here other than discuss possible reasons for this problem.

Just a reminder, customer service can be reached at 611 from your Koodo mobile or:

Photo of Ry


  • 5,552 Points 5k badge 2x thumb
Interesting. My only complaint about 800 numbers and Koodo/Telus is that BB10 doesn't auto put 1 in front of 800, and most of my conference bridges don't explicitly put 1 in the call in info. Other carriers like Bell/Rogers automatically add 1.

Edit: sorry I missed you are using a Pearl. The 8130 or 9100?

This conversation is no longer open for comments or replies.