"Unable to attach file." Galaxy s4

  • 4
  • Question
  • Updated 2 years ago
  • Answered
Hey all!  This morning I tried to send a picture via the factory installed messaging app on my s4.  I went into the app, selected the recipient, selected attachments, images, then when I selected the image to attach, it brought me back to the app and I got the message "Unable to attach file."  It didn't say anything about it being too big, or any other issue. 

I've tried restarting the phone, it didn't work.  I tried to attach a picture that I have already sent to someone, I got the same message.  My data is turned on.  The image I'm trying to send is 10 mp and 2.5 mb.  The image I tried that has worked before is 10 mp and 1.7 mb. 

Can someone help me?  Do I need to reset the phone to factory?  And if I do, how to I make sure everything I have on the phone I can get back?
Photo of Chris Leboeuf

Chris Leboeuf

  • 130 Points 100 badge 2x thumb
  • frustrated

Posted 2 years ago

  • 4
Photo of Robert

Robert, Mobile Master

  • 103,784 Points 100k badge 2x thumb
Hello. 

No you don't need to reset the phone to factory. Try using hangouts app, maybe it'll work! Worst case scenario, send it to an e-mail address. Don't reset the phone just for that! Not worth it IMO
Photo of Chris Leboeuf

Chris Leboeuf

  • 130 Points 100 badge 2x thumb
So the hangouts app does the same thing as the text messenger?  Doesn't the recipient have to have hangouts as well?
(Edited)
Photo of Chad Burr

Chad Burr, Mobile Master

  • 203,968 Points 100k badge 2x thumb
Is your network data on?

Try downloading a third party Messaging App like Chomp or gosms pro. See if you still have issues.
Photo of Chris Leboeuf

Chris Leboeuf

  • 130 Points 100 badge 2x thumb
My network data is turned on.
Photo of mike simpson

mike simpson

  • 60 Points
Go into settings>application manager>hit menu button and clear defaults

that was the fix for my customer.
Photo of Anthony Tintera

Anthony Tintera

  • 60 Points
Thanks it worked, just reset the app defaults and all works
Photo of rikkster

rikkster, Mobile Master

  • 67,084 Points 50k badge 2x thumb
While in the stock messaging app, go into Settings and see if you can adjust the maximum MMS message size to its highest value. I realize you have a Galaxy S4, on my One M9 there are three options 600K, 1000K and 3500K.
Photo of Chris Postma

Chris Postma

  • 104 Points 100 badge 2x thumb
Same thing is happening to me. "Unable to attach file" started yesterday. I've looked through everything I can think of but nothing seems to be working.
(Edited)
Photo of Chrissy Joseph

Chrissy Joseph

  • 94 Points 75 badge 2x thumb
I am having the same problem. I did do a factory reset, but it didn't help.
Photo of Chad Burr

Chad Burr, Mobile Master

  • 203,968 Points 100k badge 2x thumb
Chrissy did you read this entire thread? There are some possible solutions here, what did you already try and did that fail too?
Photo of Chrissy Joseph

Chrissy Joseph

  • 94 Points 75 badge 2x thumb
I was attempting to get thru the entire thread. LoL. I did a factory reset. I DID a Force Stop on the messaging app then cleared the data and cache. I had Verizon do a reset on their end.
Photo of Chrissy Joseph

Chrissy Joseph

  • 94 Points 75 badge 2x thumb
What is es file explorer?
Photo of Chad Burr

Chad Burr, Mobile Master

  • 203,968 Points 100k badge 2x thumb
It's an app or file manager.

Try downloading Chomp or gosms pro and using them instead of the built in Messaging App.
Photo of Chad Burr

Chad Burr, Mobile Master

  • 203,968 Points 100k badge 2x thumb
If you have a file Explorer like ES File Explorer or some similar file manager, try using that to share the file to a recipient via Mms instead of going directly to the app.

If that doesn't work then the
Next step would be to navigate to the messaging app and clear the cache and data. Unfortunately this may delete any existing messages and there is no guarantee that it will work.
Photo of Liz Hogancamp

Liz Hogancamp

  • 80 Points 75 badge 2x thumb
Thanks for this. I've been having the same issue with my phone the last couple days all of a sudden. Downloaded this and am able to send pics through the message app again.
Photo of Chris Postma

Chris Postma

  • 104 Points 100 badge 2x thumb
Yes I did clear cache and data from messenger with no luck
Photo of Chad Burr

Chad Burr, Mobile Master

  • 203,666 Points 100k badge 2x thumb
And what about the first part of my suggestion?

And did you try Chomp or Gosms pro?
(Edited)
Photo of Chris Postma

Chris Postma

  • 104 Points 100 badge 2x thumb
I downloaded es file explorer and that did work. Thank you chad. Still a bit of an extra step to send sms though
Photo of Chris Leboeuf

Chris Leboeuf

  • 130 Points 100 badge 2x thumb
I downloaded Chomp and it worked.  Thanks alot guys!
Photo of Dan Routhier

Dan Routhier

  • 60 Points
i have found if you select the picture in the gallery app then share to messaging it works
Photo of Andrea Murray Goo

Andrea Murray Goo

  • 62 Points
Jumping in here. Selecting the photo from the gallery app doesn't work for me. But I downloaded chomp and I think this will work!
Photo of Chrissy Joseph

Chrissy Joseph

  • 94 Points 75 badge 2x thumb
I don't know what I did, but it's working now. Thank you.

This conversation is no longer open for comments or replies.