"not registered on network"

  • 2
  • Question
  • Updated 1 year ago
Need help.

My koodo phone is now saying that I have no service.
I tried to call customer service to see if it was a billing issue, and it won't even connect me to that.
I have never had service problems and just looking to see what the issue could be..
Photo of Brittany Cullen

Brittany Cullen

  • 100 Points 100 badge 2x thumb

Posted 1 year ago

  • 2
Photo of David

David, Mobile Master

  • 89,270 Points 50k badge 2x thumb
Might be a corrupted SIM. Have you an opportunity to swap with another SIM or stop by a Koodo shop and have them try one for you?
Photo of Brittany Cullen

Brittany Cullen

  • 100 Points 100 badge 2x thumb
No I haven't - heading there soon.
Photo of Robert

Robert, Mobile Master

  • 103,858 Points 100k badge 2x thumb
Have you tried dealing *611 instead of the toll free number? Did you pay your bills recently?
(Edited)
Photo of Brittany Cullen

Brittany Cullen

  • 100 Points 100 badge 2x thumb
Paid recently, wouldn't allow me to call. Still said unregistered network.
Photo of Chad Burr

Chad Burr, Mobile Master

  • 203,968 Points 100k badge 2x thumb
Have you tried restarting your phone?

Make sure also that you're not set to use only 2G networks in your mobile settings.
Photo of Ranjan

Ranjan, Official Rep

  • 28,768 Points 20k badge 2x thumb
Hi Brittany - confirming that your account looks good and service hasn't been disrupted from our end (number ending in 35, correct?) Try out some of the troubleshooting tips shared above, and let us know if that helps. The folks here can offer other advice that should help you get up and running again as well. 
Photo of Jan Hope

Jan Hope

  • 4,356 Points 4k badge 2x thumb
In some cases it could be as simple as turning on and off airplane mode. I would suggest to go to settings if it is android phone and go to connections tab then to more networks and mobile networks. Set it for Koodo network not automatic and see what happened after that.
Photo of Ivan

Ivan, Mobile Master

  • 96,382 Points 50k badge 2x thumb
Please power off your phone and remove the SIM card. Re-insert the SIM card and power on the phone. This may solve your problem, but as others have pointed out, it's likely a defective SIM card.
Photo of Jan Hope

Jan Hope

  • 4,356 Points 4k badge 2x thumb
If you wouldn't mind what kind of phone you have?