"New voicemail" notifications won't go away

  • 3
  • Question
  • Updated 3 months ago
  • Answered
Does anybody else have trouble with the "New voicemail" notifications constantly showing on their phone? After I listen to my voicemail messages and delete them, it still shows up as a "New voicemail" notification on the home screen and in the notifications on the phone. I have no more voicemail messages (not even saved ones) but the notification won't go away.

I am on a Nexus 5 with Lollipop 5.1.

Thanks.
Photo of Arthur Schultz

Arthur Schultz

  • 132 Points 100 badge 2x thumb
  • frustrated

Posted 3 years ago

  • 3
Photo of Chad Burr

Chad Burr, Mobile Master

  • 203,968 Points 100k badge 2x thumb
Try calling your number from another device and leave a message. Then go in and delete the message. See if that works
Photo of Ahmad

Ahmad

  • 96,102 Points 50k badge 2x thumb
It doesnt matter if you hang up first. I have a lot of experience with this.

Look at the dates of threads you're replying to please, Steve. This thread is 4 months old. Commenting on old threads brings them to the front page and we dont want it cluttered with old posts
(Edited)
Photo of Steve D

Steve D

  • 70 Points
I tried the solutions suggested here and they didn't work for me, anyway. There don't seem to be any more current answers. I found a solution on another forum and was happy to share in case it helped someone. Hope it hells someone else.
Photo of SoleilSoleil

SoleilSoleil

  • 70 Points
I understand that this is a Koodo site, but I have a Tablet plan with Virgin mobile Canada (Data only, so no VM) and everything I tried so far is only temporary, the VM icon comes back if my phone is restarted or loose data signal. 
I called Virgin and they say it is my phone which is suppose to be a tablet.
So far the best I can do is Clear Data or Stop the "Telephony Service" on my Asus Zenfone 2. There are a few apps in the Google Play store to Clear VM icon, but they do not work with Android 5.0.

Any other ideas would be welcome, thanks in advance.
Photo of Chad Burr

Chad Burr, Mobile Master

  • 203,968 Points 100k badge 2x thumb
Try settings... Call... Clear Voicemail notification
Photo of SoleilSoleil

SoleilSoleil

  • 70 Points
Under Call settings, I do see Voicemail, but no option to clear notificaion ! I'll search and see if Asus put it somewhere else.
Photo of Robert

Robert, Mobile Master

  • 103,858 Points 100k badge 2x thumb
Do you have data enabled. I believe you need data in order for the server to communicate to your phone that you don't have anymore VM. It's only a hypothesis
Photo of Chad Burr

Chad Burr, Mobile Master

  • 203,968 Points 100k badge 2x thumb
That's done by hidden sms messages the carrier sends to your phone.
Photo of Arthur Schultz

Arthur Schultz

  • 132 Points 100 badge 2x thumb
Having data enabled doesn't have an effect. It worked fine at first. This behaviour started a couple of months after I got the phone. I never needed data enabled previously, so I don't think I should need it now.
Photo of Ahmad

Ahmad

  • 96,102 Points 50k badge 2x thumb
Chad's suggestion should fix the issue. This is a common problem.
Photo of Arthur Schultz

Arthur Schultz

  • 132 Points 100 badge 2x thumb
Tried it. Didn't work.
Photo of rikkster

rikkster, Mobile Master

  • 67,104 Points 50k badge 2x thumb
Try going to: Settings > Apps > All - scroll down to Phone and tap on Clear cache and Clear data.
Photo of Deepa Menon

Deepa Menon

  • 60 Points
Ok, press on the icon, move to the sides, options come up, listing the different categories of phone services, select voice mail and set to low importance, and that gets rid of the icon from display.
Photo of Allan

Allan, Mobile Master

  • 56,446 Points 50k badge 2x thumb
Just so you know, this thread is from 3 years ago.