Koodo Community

Community

Solved

Why am I getting charged for US usage when NOT in the US?


I was charged for US usage in Niagara Falls (Canadian side).  Also got a text from Koodo saying welcome to the US when I was in New Brunswick.  Can they do this?  Sounds like their borders are a little off.  I purposely stayed in Canada for vacation this year because the exchange rate is crazy, so I know I did not cross the border.

7 replies

Userlevel 7
Badge +4
Your phone connected to an American tower because it had a stronger signal. If you were not in the US at the time you will need to call koodo and let them know so they can credit the charges, since they don't know where you were, only which tower you were connected to.
Excellent!  Thank you:-)
Userlevel 1
This happens to me often in various locations around Victoria, BC - the stronger signal from the US seems to supplant the Canadian signal.  Whenever a charge appears on my bill I have to call customer service; most times they're quite accommodating but sometimes they will give a hard time, as if they don't believe me (Rogers is notoriously bad for this; I once had a Rogers rep tell me I should have changed my location before I answered a call, even though I didn't know I was on the US signal).  Unfortunately there doesn't seem to be a way to block the phone from switching to a US carrier, nor is there a 'welcome to Canada' text when the phone switches back to the Canadian signal to let you know you're on your home network again.
Good to know for my future travels
Userlevel 7
Badge +4
On some Android phones, you can go into More Settings => Wireless & Networks => Mobile Networks => Mobile operators => Search for available networks then force Koodo as the choice.

By default, phone will listen to the clearest signal it can get.

This is an option many people who live near the US border choose to avoid unnecessary roaming.
Userlevel 7
Badge +4
BobTheElectrician wrote:

On some Android phones, you can go into More Settings => Wireless & Networks => Mobile ...

on iPhone try Settings > Carrier, turn off automatic, and choose Koodo or Telus from the list which appears in a minute or so. You will then connect only to the Canadian network.
Userlevel 5
I call Koodo Customer Service and provide them with my border town itinerary, prior to traveling. Customer service thanks me and I've never received any Koodo text's or charges.

Reply