Koodo Community

Community

Solved

Us Roaming plan not working


I purchased a 3 day plan by texting 4545. I received a welcome message when I entered US. Then I went on a hike and it must have done something strange cause it said welcome back to Canada and check your data usage. Then I could not access data at all. I have roaming enabled. Everytime I try to use to it I get a message saying no network connection! Halp plz 🙂

5 replies

Userlevel 7
Badge +4
Hello Kim, Try restarting the phone and see if it solves the problem.
I have restarted several times and no improvement.
Userlevel 7
Badge +4
If you are in the hinterlands, LTE may not be available. On the Android side, sometimes disabling LTE forces the data connection to the more common but slower 3G protocol.

Userlevel 6
in the menu that you provided the screen shot off, try disabling LTE
Userlevel 7
Badge +4
Buying any of the Travel Add-ons on a postpaid plan only nets you a savings on your roaming fees, it does not change anything about the ability of the phone to roam. Without the Voice / Text / Data Add-on, you can still roam at pay-per-use prices.

It is a strange message, considering you seem to have good signal strength from AT&T! The welcome to Canada message is strange, too.

You may want to try resetting your cellular network settings Settings > Cellular > Cellular Data Options > Cellular Data Network > Reset settings. 

You can also try Settings > General > Reset > Reset Network Settings.

Reply