Koodo Community

Community

Solved

Unlocked iPhone 4 screen says No Service


I recently unlock my iPhone 4 - 16GB from Rogers, i just restart the phone and when i turn it back on, i was working with koodo, i made calls and send messages. but now is say on the screen NO SERVICE.

4 replies

Userlevel 5
Do you have 3G turned in under Cellular options? It's a requirement with Koodo (no GSM 2G network to fall back on).
Try putting the phone into airplane mode for about 15 sec, this usually works (and it is different from just turning the phone off and on), if this does not work then you may want to call tech support to see if they can do anything for you.
Thanks guyz, i dont know which one worked but i tried both things, turn on airplane and turn on 3G. and now it is working. But i still dont understand why did this happen and could it be happen again in near future.
Userlevel 5
It should only happen if 3G gets turned off, so if it happens again just do a quick check to see if its off it your service disappears again..

Reply