Koodo Community

Community

Solved

Unable to process on the Self Serve app


Every time I use the Koodo Self Serve app and go to check my usage it says "Unable to process your request. Please check your information and try again." Is there a way to fix this because I cannot see my usage and it's a problem.

3 replies

Userlevel 2
Make sure you're entering in the correct log in information(test on a PC first). You will get that message if the information you are entering isn't correct.
Userlevel 3
Hey Lyssa, Are you still having issues with your Self Serve app? Please keep us posted. ________________________ If you see a good answer, give it a star.
Userlevel 5
If it's on an iPhone try updating the app. Mine has worked better since the update to version 2.0 If it's still not working, the work around is to hit log out and then log back in you should be able to see your usage then. There is a glitch that the app makers have had trouble tracking down, and it seems to be tied to having "keep me logged in checked" but that's as far as I've been able to troublshoot/find a work around for.

Reply